Bug 116100 - kill(1) man page
kill(1) man page
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-18 04:57 EST by Tim Waugh
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 5.2.0-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-02 13:26:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2004-02-18 04:57:06 EST
Description of problem:
The kill(1) man page seems to be shipped by util-linux, but coreutils
provides the binary.

Version-Release number of selected component (if applicable):
coreutils-5.0-39
util-linux-2.12-2

I suggest removing the man page from util-linux, and letting coreutils
provide it.
Comment 1 Tim Waugh 2004-02-18 05:01:33 EST
Actually it's a worse mess:

$ rpm -qf /usr/bin/kill
coreutils-5.0-39
$ rpm -qf /bin/kill
util-linux-2.12-2
$ type kill
kill is a shell builtin

Should coreutils not ship a kill binary?
Comment 2 Tim Waugh 2004-02-21 12:36:20 EST
It turns out that redhat-lsb requires /usr/bin/kill but not /bin/kill.
 So I think util-linux is in the wrong here.
Comment 3 Tim Waugh 2004-02-21 12:42:57 EST
Fixed in coreutils-5.2.0-4.
Comment 4 Tim Waugh 2004-02-21 12:44:33 EST
Oops, wrong bug (meant to close bug #116463).
Comment 5 Rob Hagopian 2004-03-04 11:06:33 EST
According to the Linux Filesystem Hierarchy Standard
(http://www.pathname.com/fhs/pub/fhs-2.3.html) kill is required to be
in /bin/kill. This would imply that the problem is with redhat-lsb?
Comment 6 Elliot Lee 2004-06-02 13:26:35 EDT
FC2's util-linux has both paths available now.

Note You need to log in before you can comment on or make changes to this bug.