Bug 116106 - Update fails with an rpm unpack error installing the package under selinux
Summary: Update fails with an rpm unpack error installing the package under selinux
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: SELinux
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-18 10:39 UTC by Paul Nasrat
Modified: 2007-04-18 17:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-08 00:35:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Nasrat 2004-02-18 10:39:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
When updating failure.  Running rpm manually:

error: unpacking of archive failed on file /selinux: cpio: lsetfilecon
failed

updated under 2.6.2-1.85 with selinux.  Install succeeded under same
kernel with selinux=0 init=/bin/sh


Version-Release number of selected component (if applicable):
SysVinit-2.85-17

How reproducible:
Always

Steps to Reproduce:
1. run selinux compatible kernel from rawhide
2. rpm -Uvh SysVinit-2.85-17.i386.rpm

    

Actual Results:  Fails with rpm unpacking error error

Expected Results:  Succeeds

Additional info:

ls -alZ / reveals no context set for /selinux and / 
make relabel
make reload
retried rpm -Uvh in selinux land still fails
This may be an rpm bug in handling contexts, or you just may not be
able to do this when under selinux.
At least /sbin/init and friends are still on the filesystem.

Comment 1 Paul Nasrat 2004-02-18 11:14:46 UTC
Change component to rpm.

Talked to rjc and it is due to /selinux being unlabeled, same issue
will occur for filesystem upgrade (/proc /sys /initrd likewise)

Comment 2 Jeff Johnson 2004-04-08 00:35:10 UTC
I believe this problem is solved.


Note You need to log in before you can comment on or make changes to this bug.