Bug 116107 - redhat-install-packages fails if no install tree is present, and comps.rpm not installed
redhat-install-packages fails if no install tree is present, and comps.rpm no...
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-18 05:58 EST by Toralf
Modified: 2007-04-18 13:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 16:15:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toralf 2004-02-18 05:58:54 EST
Description of problem:
redhat-install-packages fails if it can't find an install tree -
either on a mounted CD, via the comps package, or trought the --tree
argument.

A "single package" installer should require nothing but the packages
being installed, IMO.

Version-Release number of selected component (if applicable):
1.1.8-1

How reproducible:
Every time

Steps to Reproduce:
1. Make sure there is no Red Hat dist CD in the drive.
2. rpm -e comps
3. redhat-install-packages <rpm files>
  
Actual results:
   Install Tree Not Found

   The path /mnt/cdrom does not look
   like a valid installation source 

Expected results:
Installer GUI opened

Additional info:
It doesn't look like the installer actually requires any of the files
normally found on the install tree. I did something like:

at > .discinfo <<EOF
9999999999.999999
Fake Dist
$MACHTYPE
1
base
.
pixmaps
EOF

redhat-install-packages --tree=. $*

in a script, and the GUI started as expected.

Also note that as far as I can tell, "comps" is always present after a
fresh install of RHL 9, but it is not included when upgrading from
version 7.x.
Comment 1 Toralf 2004-02-18 11:37:49 EST
Obviously, there is a missing character in the command included above
- you want "cat > .discinfo", not "at > .discinfo"

Also, it turns out that my statement about the install tree isn't
entirely true. If the packages specified are installable and all
requirements are met, only .discinfo is needed, but if there are
unresolved dependencies in the package set, the installer will fail
horribly unless base/comps.xml and the hdlist files are also present.
Also, in that case, "--tree=." won't work, either; apparently, an
absolute path is required for comps.xml to be found, so you need
"--tree=`pwd`" or similar.
Comment 2 Jeremy Katz 2005-09-21 16:15:06 EDT
This report is filed against a product which is no longer supported.  It is very
likely that the problem is resolved in the current version of Fedora Core or
scheduled to be resolved with the new system-config-packages scheduled to land
in Fedora Core 5.

Note You need to log in before you can comment on or make changes to this bug.