Bug 1161115 - [JSONRPC][engine-backend] Live resize is reported as failed while volume extenstion had succeeded
Summary: [JSONRPC][engine-backend] Live resize is reported as failed while volume exte...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.5.0
Hardware: x86_64
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Piotr Kliczewski
QA Contact: Elad
URL:
Whiteboard: infra
Depends On:
Blocks: rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-11-06 12:15 UTC by Elad
Modified: 2016-02-10 19:03 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-16 13:39:06 UTC
oVirt Team: Infra


Attachments (Terms of Use)
logs from host and engine.log and screenshot (2.72 MB, application/x-gzip)
2014-11-06 12:15 UTC, Elad
no flags Details
logs from engine&vdsm while trying the action with xml protocol at the host (73.01 KB, application/x-gzip)
2014-11-16 15:22 UTC, Amit Aviram
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 35218 master MERGED jsonrpc: diskSizeExtend missing in command_info Never
oVirt gerrit 35229 ovirt-3.5 MERGED jsonrpc: diskSizeExtend missing in command_info Never

Description Elad 2014-11-06 12:15:17 UTC
Created attachment 954421 [details]
logs from host and engine.log and screenshot

Description of problem:
I've live resize a VM disk. Checked both with block and file. The operation fails on engine while the request to extend the volume is completed successfully by vdsm. The guest sees the disk with the new updated size. 

Version-Release number of selected component (if applicable):
rhev 3.5 vt9

How reproducible:
Always, checked with block and file storage

Steps to Reproduce:
1. Create a VM with disk attached, install OS
2. Extend the disk while the VM is running
3.

Actual results:
Disk extenstion fails on engine while the disk is actually resized successfully:

engine.log:

2014-11-06 13:57:36,421 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.ExtendVmDiskSizeVDSCommand] (org.ovirt.thread.pool-7-thread-35) Failed in ExtendVmDiskSizeVDS method, for vds: green-vdsb; host: 10.35.102.1
1
2014-11-06 13:57:36,422 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.ExtendVmDiskSizeVDSCommand] (org.ovirt.thread.pool-7-thread-35) Command ExtendVmDiskSizeVDSCommand(HostName = green-vdsb, HostId = 96b45f4e-
e193-4e9e-9d9e-dcc532d0e7b8, vmId=f824b82a-471b-4ca5-8dc9-e0905f2a4a46) execution failed. Exception: ClassCastException: java.lang.Boolean cannot be cast to java.lang.String

Events in webadmin:
	
2014-Nov-06, 13:57
Failed to update VM 'VM-2' with the new volume size. VM restart is recommended.



vdsm.log:

e9105a67-7cac-4fdb-9e71-ac93b12f4ff3::DEBUG::2014-11-06 13:57:36,240::lvm::288::Storage.Misc.excCmd::(cmd) /usr/bin/sudo -n /sbin/lvm lvextend --config ' devices { preferred_names = ["^/dev/mapper/"] ignore_suspen
ded_devices=1 write_cache_state=0 disable_after_error_count=3 obtain_device_list_from_udev=0 filter = [ '\''a|/dev/mapper/360060160f4a03000d65228391002e411|'\'', '\''r|.*|'\'' ] }  global {  locking_type=1  priori
tise_write_locks=1  wait_for_locks=1  use_lvmetad=0 }  backup {  retain_min = 50  retain_days = 0 } ' --autobackup n --size 9216m aa81f202-2540-4190-9184-b6fd116a2d2a/5f8276dd-eea3-4cb8-ae17-ea90ca4a67be (cwd None
)


The LV is updated to the new size:

 5f8276dd-eea3-4cb8-ae17-ea90ca4a67be aa81f202-2540-4190-9184-b6fd116a2d2a -wi-ao----   9.00g



Guest sees the disk with its new size



Expected results:
Operation should be reported with its true result

Additional info:
logs from host and engine.log and screenshot

Comment 1 Elad 2014-11-06 12:18:36 UTC
rhevm-3.5.0-0.19.beta.el6ev.noarch
Host OS: Red Hat Enterprise Linux Server release 7.0 (Maipo)
vdsm-4.16.7.3-1.el7ev.x86_64
libvirt-daemon-1.1.1-29.el7_0.3.x86_64
qemu-kvm-rhev-1.5.3-60.el7_0.10.x86_64
selinux-policy-3.13.1-6.el7.noarch
sanlock-3.1.0-2.el7.x86_6

Comment 3 Amit Aviram 2014-11-16 15:22:27 UTC
Created attachment 957997 [details]
logs from engine&vdsm while trying the action with xml protocol at the host

This bug was initially assigned to Storage team- after looking at the bug it seems to be that the problem is related to the host's JSON protocol.

the logs that was initially attached are logs generated while the host's protocol was JSON. this attachment is the logs while the protocol is XML which works with no errors.

Comment 4 Allon Mureinik 2014-11-17 07:13:23 UTC
Piotr, can you take a look please?

Comment 5 Piotr Kliczewski 2014-11-17 09:51:08 UTC
It looks like command_info is missing VM_diskSizeExtend

Comment 6 Piotr Kliczewski 2014-11-24 14:04:16 UTC
*** Bug 1167257 has been marked as a duplicate of this bug. ***

Comment 8 Elad 2014-12-21 09:23:45 UTC
ExtendVmDiskSizeVDSCommand is now reported with its true result.

Verified using rhev 3.5 vt13.4


Note You need to log in before you can comment on or make changes to this bug.