Bug 1161171 - cups can't disable SSLv3
Summary: cups can't disable SSLv3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cups
Version: 6.6
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Tim Waugh
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 1075802 1161172 1161218
TreeView+ depends on / blocked
 
Reported: 2014-11-06 15:01 UTC by Eric Rich
Modified: 2019-07-11 08:19 UTC (History)
4 users (show)

Fixed In Version: cups-1.4.2-68.el6
Doc Type: Bug Fix
Doc Text:
It was not possible to disable Secure Sockets Layer (SSLv3) and keep other secure protocols enabled in CUPS. This left CUPS users vulnerable to the POODLE attack (CVE-2014-3566), and needing to deploy the stunnel utility for mitigation. This update disables SSLv3 support by default. For users who need to continue using SSLv3, an SSLOptions configuration directive has been added to the cupsd.conf file for the cupsd service and to the client.conf file for the client programs.
Clone Of:
: 1161172 1161218 (view as bug list)
Environment:
Last Closed: 2015-07-22 06:54:53 UTC


Attachments (Terms of Use)
cups-str4476.patch (RHEL-6) (14.97 KB, patch)
2014-11-07 18:17 UTC, Tim Waugh
no flags Details | Diff
cups-str4476.patch (RHEL-6) (17.19 KB, patch)
2015-01-09 14:37 UTC, Tim Waugh
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1346 normal SHIPPED_LIVE cups bug fix and enhancement update 2015-07-20 17:59:51 UTC
Red Hat Knowledge Base (Solution) 1334823 None None None Never

Description Eric Rich 2014-11-06 15:01:03 UTC
Description of problem:

Cups can't disable SSLv3, so stunnel is the only workarround, per https://access.redhat.com/site/solutions/1234843

Please backport, the Upstream Fix: http://www.cups.org/str.php?L4476

Comment 2 Tim Waugh 2014-11-07 18:17:13 UTC
Created attachment 955041 [details]
cups-str4476.patch (RHEL-6)

Comment 8 Tim Waugh 2015-01-09 14:37:59 UTC
Created attachment 978183 [details]
cups-str4476.patch (RHEL-6)

Improved patch.

Comment 11 errata-xmlrpc 2015-07-22 06:54:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1346.html


Note You need to log in before you can comment on or make changes to this bug.