Bug 1161178 - Request update of lazarus to 1.2.4 or higher.
Summary: Request update of lazarus to 1.2.4 or higher.
Keywords:
Status: CLOSED DUPLICATE of bug 1209477
Alias: None
Product: Fedora
Classification: Fedora
Component: lazarus
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Joost van der Sluis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1150453
TreeView+ depends on / blocked
 
Reported: 2014-11-06 15:19 UTC by Richard Shaw
Modified: 2015-05-06 12:45 UTC (History)
3 users (show)

Fixed In Version: fpc-2.6.4-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-21 19:27:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1173261 None None None Never

Internal Links: 1173261

Description Richard Shaw 2014-11-06 15:19:35 UTC
Description of problem:
The latest release of lazarus if 1.2.6 released in October but my package, cqrlog only requires 1.2.4.

Although I would like f20 updated it appears to be on 1.0.x but at least f21+ would be great.

Comment 1 Federic 2014-11-08 19:18:51 UTC
Best shot from Fedora 20 is 1.0.14 from updates-testing repo. However, this is now end of line for that release ( last bugfix ) and will not receive any more bug fixes. 

It seems Fedora is still "testing" something that is already history from the developer's point of view. 

As an IDE, Lazarus presumably does not have a long dependency chain. Wouldn't it make more sense to have something in the current release range? 

Fed20 is still the main stable Fedora release and even the "testing" release of lazarus-1.0.14 is nearly two years old now.  It does not seem right that I'd need to move to a beta distro to get a version of Lazarus that is still supported.

Comment 2 Federic 2014-11-08 19:44:46 UTC
Looking at the tonne of bug fixes since 1.2.0, it seems a silly to still be "testing" 1.0.14 ;)


http://wiki.lazarus.freepascal.org/Lazarus_1.2_fixes_branch

Comment 3 Jaroslav Reznik 2015-03-03 16:28:33 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 4 Fedora Update System 2015-04-01 11:45:27 UTC
fpc-2.6.4-1.fc22,lazarus-1.4-0.2.RC2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/fpc-2.6.4-1.fc22,lazarus-1.4-0.2.RC2.fc22

Comment 5 Fedora Update System 2015-04-02 01:42:47 UTC
Package fpc-2.6.4-1.fc22, lazarus-1.4-0.2.RC2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fpc-2.6.4-1.fc22 lazarus-1.4-0.2.RC2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5303/fpc-2.6.4-1.fc22,lazarus-1.4-0.2.RC2.fc22
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-04-21 19:27:03 UTC
fpc-2.6.4-1.fc22, lazarus-1.4-0.2.RC2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Raphael Groner 2015-05-06 12:45:41 UTC
This bug is not fixed rightly. I'll mark it as duplicate of a new update request to latest upstream version.

*** This bug has been marked as a duplicate of bug 1209477 ***


Note You need to log in before you can comment on or make changes to this bug.