Bug 1161238 - [fix available]Attached template file master has outline previews removed from numbering rules, so preview doesn't show bullets, but when new slides inherit the true numbering rules and show a bullet.
Summary: [fix available]Attached template file master has outline previews removed fro...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libreoffice
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Caolan McNamara
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-06 17:47 UTC by Jim Tyrrell
Modified: 2015-11-23 16:14 UTC (History)
4 users (show)

Fixed In Version: 4.3.7.2-5.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-23 16:14:22 UTC
Target Upstream Version:


Attachments (Terms of Use)
Master Slide (88.67 KB, image/png)
2014-11-06 17:47 UTC, Jim Tyrrell
no flags Details
Bulleted List Showing (88.67 KB, image/png)
2014-11-06 17:48 UTC, Jim Tyrrell
no flags Details
Template OTP File that shows the issue. (92.80 KB, application/vnd.oasis.opendocument.presentation)
2014-11-06 17:48 UTC, Jim Tyrrell
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2197 normal SHIPPED_LIVE libreoffice bug fix and enhancement update 2015-11-23 21:13:16 UTC

Description Jim Tyrrell 2014-11-06 17:47:41 UTC
Created attachment 954565 [details]
Master Slide

Description of problem:
When I created this template file and insert a new slide, I get a bulleted list, yet the Master file does not seem to show these bullets.  Why is the Master slide not the default inserted slide.  Something feels very odd here.

Version-Release number of selected component (if applicable):
Mac Version 4.3.3

How reproducible:


Steps to Reproduce:
1. With the attached OTP happens every single time.
2.
3.

Actual results:


Expected results:
I would expect the master to be used when inserting a new slide.

Additional info:

Comment 1 Jim Tyrrell 2014-11-06 17:48:07 UTC
Created attachment 954566 [details]
Bulleted List Showing

Comment 2 Jim Tyrrell 2014-11-06 17:48:34 UTC
Created attachment 954567 [details]
Template OTP File that shows the issue.

Comment 4 Caolan McNamara 2014-11-07 10:20:51 UTC
what we have here I believe is what you get in the absence of the up and coming 4.4 feature where using the "bullets off" button in impress's master view of outlines actually changes the underlying style (https://wiki.documentfoundation.org/ReleaseNotes/4.4#Text_of_Master_View_Object_Previews) where the old behavior was to set the *preview* as not belonging to the numbering but leaving the actual numbering rules untouched. i.e. the bullets and numbering button at the far right reveals that the numbering rules are "normal" and have a bullet at level 1, which the preview itself has no bullet, so new slides will still get a bullet as per the rules.

So, the question then is, when the above feature is in place, if it is "safe" at load/master view creation time to effectively throw away the "cached in file format" conflicting formatting on the preview in order to resync it with the numbering rule it is supposed to be a preview of.

Comment 5 Caolan McNamara 2014-11-07 17:12:50 UTC
I have a fix for this now.

Comment 6 Jim Tyrrell 2014-11-07 17:17:38 UTC
I also think this issues comes from the combination of how master and styles overlay with each other.  Clicking a new slide is somewhat indeterministic as you can not see what is going to created or inserted.  After learning a little more about LibreOffice I am not sure what the issue is here.

Is it that Keynote and PPT seem to combine the notions of Masters and Layouts into just Masters so its a doc issue and training issue.

Is it that the UI doesn't exactly show you what you are inserting into the deck.

Is it that Master is really unelectable Background at least in the context of what I was familiar with.

Just not sure what to say or ask for in the context of this issue.

Comment 8 Caolan McNamara 2014-11-07 20:44:57 UTC
you want it to "just work", it will with the combination of this fix and another one  (http://cgit.freedesktop.org/libreoffice/core/log/8a5b3971057237b178f7e65437deec766b56f9c4). The issue is really that the "previews" in the master view come "unstuck" from the styles+outline numbering that they are supposed to be a preview of so you end up making changes to the previews that don't get reflected into the underlying styles. So part one was to cut off the possibility of that happening (the toggle bullets thing) and part two is to "fix" the previews in existing documents.

Well, at least that's my take on it.

Comment 13 Bill Sanford 2015-09-11 18:03:35 UTC
Verified with RHEL-7.2-20150904.0 & libreoffice-4.3.7.2-5.el7.x86_64

Comment 15 errata-xmlrpc 2015-11-23 16:14:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2197.html


Note You need to log in before you can comment on or make changes to this bug.