Bug 1161246 - [gtk3] firefox built with gtk3 mixes gtk2 (and fails to launch) when accessibility is enabled somehow
Summary: [gtk3] firefox built with gtk3 mixes gtk2 (and fails to launch) when accessib...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1172949 (view as bug list)
Depends On:
Blocks: F22AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2014-11-06 18:10 UTC by Yanko Kaneti
Modified: 2014-12-15 08:46 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-15 08:44:44 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Mozilla Foundation 1110211 0 None None None Never

Description Yanko Kaneti 2014-11-06 18:10:05 UTC
Description of problem:
Firefox doesn't start with some gtk criticals when the "Screen reader" or "Screen keyboard" accessibility setting are on.

strace shows the process opening libgail.so from gtk2

Version-Release number of selected component (if applicable):
firefox-33.0-4.fc22.x86_64

How reproducible:
Always

Comment 1 Yanko Kaneti 2014-11-12 12:27:38 UTC
no change with firefox-33.1-1.fc22.x86_64

Comment 2 Martin Stransky 2014-11-19 12:09:57 UTC
Can you provide me some reproduction steps for it? I'm unable to launch the on-screen keyboard. Also, to you run gnome-shell or something else?

Comment 3 Yanko Kaneti 2014-11-19 12:13:59 UTC
Yes this is under gnome-shell.
- go to control center -> Universal access
- enable "Screen Reader" or "Screen Keyboard"

Try to start firefox.

Comment 4 Martin Stransky 2014-12-11 15:58:14 UTC
set GNOME_ACCESSIBILITY=1 does the trick.

Comment 5 Adam Williamson 2014-12-12 19:19:09 UTC
*** Bug 1172949 has been marked as a duplicate of this bug. ***

Comment 6 Adam Williamson 2014-12-12 19:21:05 UTC
Proposing as an Alpha blocker, conditional violation of https://fedoraproject.org/wiki/Fedora_22_Alpha_Release_Criteria#Required_applications - "It must be possible to run the default web browser and a terminal application from all release-blocking desktop environments." - when a11y is enabled, somehow, which seems relatively easy to do.

Comment 7 Martin Stransky 2014-12-15 08:44:44 UTC
A workaround which temporary disables ATK in Firefox just hit the rawhide, package firefox-34.0-8.fc22.

Comment 8 Martin Stransky 2014-12-15 08:46:16 UTC
Upstream bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1110211


Note You need to log in before you can comment on or make changes to this bug.