Bug 116135 - bash auto-completion has late response
bash auto-completion has late response
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-18 10:49 EST by Ivan Sedo
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-29 13:29:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Sedo 2004-02-18 10:49:38 EST
Description of problem: 
 
bash auto-completion has late response 
 
if I use tab (auto-completion) it don't work immediatelly - the word 
is not completed to maximum common prefix of some word wich do have 
a common prefix, but it does complete it after any key press 
 
 
Version-Release number of selected component (if applicable): 
bash-2.05b-36 
 
How reproducible: 
always 
 
Steps to Reproduce: 
1. find some folder with files which do have common prefix 
2. type a shorter prefix of that prefix 
3. press tab - nothing happens 
4. press any key - word is completed 
   
Actual results: 
bash auto-complete don't work well 
 
Expected results: 
word should be tab auto-completed right after pressing tab 
 
Additional info:
Comment 1 Tim Waugh 2004-02-18 10:53:14 EST
Works for me.  What does 'locale' say?
Comment 2 Colin Charles 2004-03-03 03:52:21 EST
Also using bash-2.05b-36, I tried this and it seems to be an issue - I
have to press the tab key twice before I get a choice. An example:

OOo_680m22
OOo_680m26
OOo_680m26_LinuxIntel_install.tar.gz
OpenOffice.org1.1.0
OpenOffice.org680
OpenOffice.org - Is it an alternative to MS Office.sxi

If I do "ls O", I don't get any response as to the options available.
Pressing the tab key the second time, shows the above output.

Locale is en_US.UTF-8 (Fedora standard).

That said, this bug is *not* Fedora specific. I think its an upstream
bash issue, since I have also been able to repeat it on Debian.
Comment 3 Tim Waugh 2004-03-03 04:27:27 EST
Colin -- that is expected (and documented) behaviour, and different to
the reported behaviour in this bug.  You have typed the entire common
prefix, not a shorter prefix.

Note You need to log in before you can comment on or make changes to this bug.