Bug 1161453 - [whql][vioscsi]Job named by SCSI Compliance Test (LOGO) failed on win2k8-R2 and win8-64 guest
Summary: [whql][vioscsi]Job named by SCSI Compliance Test (LOGO) failed on win2k8-R2 a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1288337
TreeView+ depends on / blocked
 
Reported: 2014-11-07 07:37 UTC by Min Deng
Modified: 2016-11-04 08:43 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2016-11-04 08:43:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description Min Deng 2014-11-07 07:37:19 UTC
Description of problem:
Job named by SCSI Compliance Test (LOGO) failed on win2k8-R2 and win8-64 guest

Version-Release number of selected component (if applicable):
 Build info,
  kernel-3.10.0-186.el7.x86_64
  qemu-kvm-rhev-2.1.2-1.el7.x86_64
  virtio-win-prewhql-01-93

How reproducible:
4/4

Steps to Reproduce:
1.boot up guest with virtio scsi driver installed for win2k8-R2 and win8-64 platform
example,

win2008-R2
  /usr/libexec/qemu-kvm -name 093SCS2008R29LV -enable-kvm -m 4G -smp 4 -uuid 5607c54e-3815-4a23-b951-85ac1366d239 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/093SCS2008R29LV,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=093SCS2008R29LV,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2008_r2_standard_enterprise_datacenter_and_web_with_sp1_x64_dvd_617601.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=093SCS2008R29LV.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:57:7b:2a:81,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:4 -vga cirrus -device virtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x7 -drive file=093SCS2008R29LV_test.raw,if=none,id=drive-scsi-disk0,format=raw,serial=mike_cao,cache=none -device scsi-hd,bus=scsi0.0,drive=drive-scsi-disk0,id=scsi-disk0

Win8-64
 /usr/libexec/qemu-kvm -name 093SCSWIN864Q5Q -enable-kvm -m 6G -smp 4 -uuid 5828714f-5706-4bdf-b58d-7f8c76343d48 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/093SCSWIN864Q5Q,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=093SCSWIN864Q5Q,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_8_enterprise_x64_dvd_917522.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=093SCSWIN864Q5Q.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:50:02:6d:a5,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:5 -vga cirrus -device virtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x7 -drive file=093SCSWIN864Q5Q_test.raw,if=none,id=drive-scsi-disk0,format=raw,serial=mike_cao,cache=none -device scsi-hd,bus=scsi0.0,drive=drive-scsi-disk0,id=scsi-disk0

2.Submit the job
3.

Actual results:
The job could not pass

Expected results:
The job could pass


Additional info:
One related bug 1003158 and upload hck files as well.

Comment 9 Vadim Rozenfeld 2016-07-13 05:13:54 UTC
Hi Min,

is it still reproducible in 7.3?

Thanks,
Vadim.

Comment 10 Yu Wang 2016-07-13 06:37:33 UTC
(In reply to Vadim Rozenfeld from comment #9)
> Hi Min,
> 
> is it still reproducible in 7.3?
> 
> Thanks,
> Vadim.

Hi Vadim, 

According to our WHQL vioscsi test for virtio-win-prewhql-120, this job has passed on RHEL7.3. So this bug has been fixed.

Thanks
Yu Wang

Comment 11 Yu Wang 2016-07-13 06:40:01 UTC
according comment#10, change status to verified

Comment 14 errata-xmlrpc 2016-11-04 08:43:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.