Bug 1161456 - Navigation issue on 'Red Hat access' links
Summary: Navigation issue on 'Red Hat access' links
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: JON 3.3.0
Assignee: Libor Zoubek
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks: JON3-11
TreeView+ depends on / blocked
 
Reported: 2014-11-07 07:44 UTC by Jeeva Kandasamy
Modified: 2015-11-02 00:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-07 14:25:02 UTC
Type: Bug


Attachments (Terms of Use)

Description Jeeva Kandasamy 2014-11-07 07:44:33 UTC
Description of problem:
Sometimes to access 'Red Hat Access' links needs few extra clicks.

Example: 
1. Navigate to 'Red Hat Access->Support->My Cases' from there click 'Open a New Support Case'
2. After completion of opening new support case I want to go back to 'My Cases' to see my cases I followed 'Red Hat Access->Support->My Cases', but it does not work. I have to navigate to some other windows and again come back to 'Red Hat Access->Support->My Cases'

Seems on address bar it holds 'https://hostname:7443/coregui/#Support/MyCases' and assumes already we are in the same page.

Version-Release number of selected component (if applicable):
JBoss Operations Network
Version : 3.3.0.CR01
Build Number : 08c2f39:6ac97ac
GWT Version : 2.5.0
SmartGWT Version : 3.0p

Browser: Firefox 33.0

How reproducible:
always

Comment 1 Libor Zoubek 2014-11-07 14:25:02 UTC
There's no way I could fix this. When navigating in RHA, URL in urlbar does not change, because whole app is IFRAMEd. It's also not possible to listen to from outside the iframe on stuff inside (so we could update URL based on what happened in iframe).

Then .. when /MyCases is in url bar (although inside RHA app you've created a support case) and you attempt to navigate to same URL, GWT won't even care to try to update current view, because it knows you are looking at the right view.


Note You need to log in before you can comment on or make changes to this bug.