Bug 116147 - Authoring Kit does not control component ordering
Authoring Kit does not control component ordering
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: APLAWS (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Daniel Berrange
:
Depends On: 116148
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-18 11:32 EST by James Kearns
Modified: 2007-04-18 13:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-10 09:20:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Kearns 2004-02-18 11:32:52 EST
Description of problem: 
I used the Authoring kit to create the new "First Time Article" 
content type.
Using the authoring kit to create a content type based on Article 
populated the Basic Property component with 
com.arsdigita.cms.ui.authoring.PageCreateDynamic. This different to 
the component in Article, (which is 
com.arsdigita.cms.ui.authoring.PageCreate)
so I edited this in "First Time Article" by removing Dynamic.
I found that the Authoring steps produced did not relate to the the 
item components I was using. At which point I consulted Arturo. See 
additional information below.


Version-Release number of selected component (if applicable):


How reproducible: 
Haven't tried to reproduce.


Steps to Reproduce:
1. Add content type in Content types tab. Select Article as parent 
content type.
2. Use edit, delete and add step in Authoring kit details
3. Now create content using this new content type.
  
Actual results:
I found I had unexpected Authoring steps. An example was 
article.authoring.image.title which appeared as a step under Body 
Text. Even though I had only two components in the kit, namely:
com.arsdigita.cms.ui.authoring.PageCreate 
and
com.arsdigita.cms.ui.authoring.TextPageBody


Expected results:
Basing the new content type on Article should have given me the same 
steps as the Article content type. I could then remove for example 
the image component.  This would make this new content type easier 
for a first time user.


Additional info:
Arturo thought this was to be disabled pending getting it working 
reliably. We would want you to disable it until fixed.
I notice article.authoring.image.title does not now appear in Content 
Centre>Content section: content>Z_Test_Area>James>aplaws+plus QA>New 
Users>Content item: My First Go (en)
Perhaps this means you have fixed this already.
Comment 1 Daniel Berrange 2004-02-23 07:27:00 EST
Editing of authoring kits is not intended to be done by
Administrators. It is a low level facility for developers installing &
configuring the system. This UI will be removed in a future build.
Comment 2 Daniel Berrange 2004-03-10 09:20:26 EST
This UI is now removed.

Note You need to log in before you can comment on or make changes to this bug.