Bug 1161768 - [RFE] certmonger: add support for scep for certificates auto enrollment
Summary: [RFE] certmonger: add support for scep for certificates auto enrollment
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: certmonger
Version: 6.6
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: 6.7
Assignee: Nalin Dahyabhai
QA Contact: Kaleem
Aneta Šteflová Petrová
URL:
Whiteboard:
Keywords: FutureFeature, Reopened
Depends On: 1140241
Blocks: 1075802
TreeView+ depends on / blocked
 
Reported: 2014-11-07 20:11 UTC by Alfredo Moralejo
Modified: 2019-07-11 08:20 UTC (History)
13 users (show)

(edit)
certmonger supports SCEP

The *certmonger* service has been updated to support the Simple Certificate Enrollment Protocol (SCEP). For obtaining certificates from servers, you can now offer enrollment over SCEP.
Clone Of:
(edit)
Last Closed: 2015-07-22 07:17:28 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1379 normal SHIPPED_LIVE certmonger bug fix and enhancement update 2015-07-20 17:58:28 UTC

Description Alfredo Moralejo 2014-11-07 20:11:45 UTC
Description of problem:

Customer is asking for a method to implement auto-enrollment of certificates from Microsoft PKI in RHEL6 systems. As the information provided the optimal way is to implement SCEP protocol client in certmonger however other alternatives may be valid if available.

Version-Release number of selected component (if applicable):

RHEL6

How reproducible:

Allways.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 9 Ellen Newlands 2014-12-16 15:44:46 UTC
We have evaluated this request and at this time we have chosen to defer action.  We will consider this request in a future version of the product.

Comment 13 Nalin Dahyabhai 2015-02-28 02:34:06 UTC
0.77.1 implements the later drafts well enough to succeed when pointed at my test environment (WS 2012 R2, lone server in a lone forest), but is not confirmed to work properly with anything else yet.

Comment 21 Kaleem 2015-06-08 14:18:24 UTC
Verified.

Automated test cases executed against build certmonger.x86_64 0:0.77.5-1.el6, no regression found.

Comment 23 errata-xmlrpc 2015-07-22 07:17:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1379.html


Note You need to log in before you can comment on or make changes to this bug.