Bug 116179 - gpm fails with kernel 2.6.2-1.85
gpm fails with kernel 2.6.2-1.85
Product: Fedora
Classification: Fedora
Component: gpm (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-02-18 14:38 EST by tom
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-02-19 00:20:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description tom 2004-02-18 14:38:22 EST
Description of problem:
gpm gives Oops messessage when trying to enable console
mouse. Worked with kernel 2.6.1-1.65 dosent work with 2.6.2-1.85

Version-Release number of selected component (if applicable):

How reproducible:
/etc/rc.d/init.d/gpm restart

Steps to Reproduce:
Actual results:

Feb 18 14:36:39 venom gpm: gpm shutdown failed
Feb 18 14:36:39 venom gpm[1684]: O0o.oops(): [gpm.c(937)]:
Feb 18 14:36:39 venom gpm[1684]: Could not open /dev/psaux.
Feb 18 14:36:39 venom gpm: O0o.oops(): [gpm.c(937)]: Could not open
Feb 18 14:36:39 venom gpm: gpm startup succeeded

Expected results:

Additional info:

hardware is an IBM thinkpad A20m
Comment 1 Bill Nottingham 2004-02-19 00:20:35 EST
Change your /dev/mouse to point to /dev/input/mice instead of /dev/psaux.
Comment 2 Eido Inoue 2004-02-19 10:25:04 EST
Shouldn't gpm default to /dev/input/mice if it exists?
Comment 3 tom 2004-02-19 17:27:39 EST
this worked
cd /dev/
mv psaux psaux-orig
ln -s /dev/input/mice psaux

/etc/rc.d/init.d/gpm start


Note You need to log in before you can comment on or make changes to this bug.