Bug 1161836 - Glabels is crashing when clicking on File New.
Summary: Glabels is crashing when clicking on File New.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: glabels
Version: 21
Hardware: All
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Gordon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1163730 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-08 11:36 UTC by Stefan Held
Modified: 2014-11-27 08:37 UTC (History)
4 users (show)

Fixed In Version: glabels-3.2.1-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-16 14:39:15 UTC
Type: Bug


Attachments (Terms of Use)

Description Stefan Held 2014-11-08 11:36:22 UTC
Description of problem:

If you try to create a new Label Glabel is crashing.

Version-Release number of selected component (if applicable):

Actual in F21 Beta 3.2.x

How reproducible:


Steps to Reproduce:
1. Start Glabel
2. Klick on New
3. Or go to the Menu and click New

Actual results:

Crash.

Expected results:

Edit a new Label

Additional info:

The Bug is fixed in the git repo.

https://git.gnome.org/browse/glabels/commit/?h=glabels-3_2&id=cd9a551899ea66a5083e68b23992a39b68e13b94

https://git.gnome.org/browse/glabels/commit/?h=glabels-3_2&id=165f372e3b0d3bcd1088feac3ba3ab0aa8257777

After including of the patches to the actual source rpm, it builds installs and even better it runs again. 

Please provide the patches in the official rpms.

Comment 1 Peter Gordon 2014-11-12 16:39:26 UTC
Sorry for the delay. Later today I'm going to update Fedora's glabels to 3.2.1 which includes this fix.

Comment 2 Fedora Update System 2014-11-12 20:14:39 UTC
glabels-3.2.1-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/glabels-3.2.1-1.fc21

Comment 3 Fedora Update System 2014-11-12 20:44:47 UTC
glabels-3.2.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/glabels-3.2.1-1.fc20

Comment 4 Fedora Update System 2014-11-13 18:05:49 UTC
Package glabels-3.2.1-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glabels-3.2.1-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-14793/glabels-3.2.1-1.fc21
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-11-16 14:39:15 UTC
glabels-3.2.1-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Peter Gordon 2014-11-16 18:40:51 UTC
*** Bug 1163730 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2014-11-27 08:37:00 UTC
glabels-3.2.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.