Bug 1161852 - Bijiben (GNOME Notes) should check whether Notes folder is available on an ownCloud server before trying to store notes in it
Summary: Bijiben (GNOME Notes) should check whether Notes folder is available on an ow...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bijiben
Version: 21
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Pierre-Yves Luyten
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-08 13:50 UTC by Jörg BUCHMANN
Modified: 2015-05-04 19:22 UTC (History)
6 users (show)

Fixed In Version: aisleriot-3.14.2-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-15 09:11:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 739529 None None None Never

Description Jörg BUCHMANN 2014-11-08 13:50:35 UTC
Description of problem:
I have set up correctly my OwnCloud account in Fedora 21. Everything works fine, execpt when I choose in Notez 3.14.1 to save my notes in my OwnCloud account. Once I relaunch Notes, all my notes have disappeared.


Version-Release number of selected component (if applicable):
Fedora 21 / Notes 3.14.1

How reproducible:
see Description

Steps to Reproduce:
1. Setup an OwnCloud account
2. Open Notes and choose to save the notes in the OwnCloud account
3. Create a note and close the program
4. Open Notes again and you will see that the notes supposed to be saved, have disappeared.

Actual results:
The notes are not saved.

Expected results:
The notes should be saved

Additional info:

Comment 1 Othman Madjoudj 2014-11-08 14:15:39 UTC
Hi Jörg, sticky-notes is different application (pastebin web app), not part of OwnCloud, you issue seems with OwnCloud/Notes app.

Assigning this bug to OwnCloud maintainers.

Comment 2 Adam Williamson 2014-11-08 16:51:22 UTC
Well, he's actually reporting a bug in GNOME's Notes application's sync with an ownCloud server. I can reproduce it too. It seems to try and 'PUT' notes to remote.php/webdav/Notes and then PROPFIND the same location. only trouble is, I can't see that ownCloud actually implements that at all. Not entirely sure what the story is, and whether this is a capability OC is expected to provide that my package doesn't for some reason, or if the Notes app is just doing the wrong thing.

I'll pull in Kalev, see if he has any idea.

Comment 3 Adam Williamson 2014-11-08 16:57:52 UTC
Ah. https://github.com/owncloud/core/wiki/Apps indicates that the Notes OC app implements this:

" Notes (WebDAV, API)

    Notes are stored in the »Notes« subfolder, so you can simply use the sync apps to access and edit them on mobile and desktop"

However, the Notes app is not a part of the OC core and is not actually marked as being OC 7-compatible, so OC 7 users cannot even install it from the app store. It is not OK for Bijiben to simply assume that if an OC GOA is configured, the Notes app will be installed and the remote.php/webdav/Notes interface available; it should test it. The server returns a 404 when it's not available. Here's a server log of me configuring Bijiben to use OC as a backend then creating a note, quitting, and starting up again:

192.168.1.5 - adamw [08/Nov/2014:08:44:01 -0800] "PROPFIND /owncloud/remote.php/webdav/Notes/ HTTP/1.1" 404 283
192.168.1.5 - adamw [08/Nov/2014:08:44:22 -0800] "PROPFIND /owncloud/remote.php/webdav/Notes/86d7d54c-cce6-4c41-8463-677ac10b8c89.txt HTTP/1.1" 404 324
192.168.1.5 - adamw [08/Nov/2014:08:44:30 -0800] "PUT /owncloud/remote.php/webdav/Notes/86d7d54c-cce6-4c41-8463-677ac10b8c89.txt HTTP/1.1" 404 283
192.168.1.5 - adamw [08/Nov/2014:08:44:30 -0800] "PROPFIND /owncloud/remote.php/webdav/Notes/86d7d54c-cce6-4c41-8463-677ac10b8c89.txt HTTP/1.1" 404 324
192.168.1.5 - adamw [08/Nov/2014:08:44:34 -0800] "PROPFIND /owncloud/remote.php/webdav/Notes/86d7d54c-cce6-4c41-8463-677ac10b8c89.txt HTTP/1.1" 404 324
192.168.1.5 - adamw [08/Nov/2014:08:44:37 -0800] "PROPFIND /owncloud/remote.php/webdav/Notes/Test%20note%20for%20OC%20sync..txt HTTP/1.1" 404 310
192.168.1.5 - adamw [08/Nov/2014:08:44:37 -0800] "PUT /owncloud/remote.php/webdav/Notes/Test%20note%20for%20OC%20sync..txt HTTP/1.1" 404 283
192.168.1.5 - adamw [08/Nov/2014:08:44:38 -0800] "PROPFIND /owncloud/remote.php/webdav/Notes/Test%20note%20for%20OC%20sync..txt HTTP/1.1" 404 310
192.168.1.5 - adamw [08/Nov/2014:08:46:02 -0800] "PROPFIND /owncloud/remote.php/webdav/Notes/ HTTP/1.1" 404 283

the server's sending it 404s all along, but it just blithely continues.

Comment 4 Adam Williamson 2014-11-08 17:03:49 UTC
actually, as it's just a WebDAV filesystem location, I suppose Bijiben could simply create it if it doesn't exist, if all it's doing is putting a simple file there. The notes app doesn't really need to be present on the server for it to at least serve as a storage backend, I guess.

Comment 5 Pierre-Yves Luyten 2014-11-08 18:24:34 UTC
Yes Bijiben is the correct application for this ticket ; I thought the folder check was already done which is the case for local notes.

A first look at the code and it seems indeed no check is done, thus I will amend upstream code tonight. The admendment should be simple enough to be backported.

Comment 6 Fedora Update System 2014-11-12 22:18:45 UTC
aisleriot-3.14.2-1.fc21,appstream-data-21-16.fc21,at-spi2-core-2.14.1-1.fc21,bijiben-3.14.2-1.fc21,cheese-3.14.2-1.fc21,control-center-3.14.2-1.fc21,eog-3.14.2-2.fc21,eog-plugins-3.14.1-1.fc21,epiphany-3.14.2-1.fc21,file-roller-3.14.2-1.fc21,four-in-a-row-3.14.2-1.fc21,gedit-3.14.1-1.fc21,gedit-plugins-3.14.1-1.fc21,glib2-2.42.1-1.fc21,gnome-boxes-3.14.2-1.fc21,gnome-chess-3.14.1-1.fc21,gnome-color-manager-3.14.2-1.fc21,gnome-contacts-3.14.2-1.fc21,gnome-desktop3-3.14.2-1.fc21,gnome-devel-docs-3.14.2-1.fc21,gnome-dictionary-3.14.2-1.fc21,gnome-disk-utility-3.14.0-1.fc21,gnome-klotski-3.14.2-1.fc21,gnome-logs-3.14.2-1.fc21,gnome-maps-3.14.2-1.fc21,gnome-music-3.14.2-1.fc21,gnome-online-accounts-3.14.2-1.fc21,gnome-packagekit-3.14.2-1.fc21,gnome-photos-3.14.2-1.fc21,gnome-robots-3.14.2-1.fc21,gnome-settings-daemon-3.14.2-1.fc21,gnome-shell-3.14.2-1.fc21,gnome-shell-extensions-3.14.2-1.fc21,gnome-software-3.14.2-2.fc21,gnome-sound-recorder-3.14.2-1.fc21,gnome-sudoku-3.14.2-1.fc21,gnome-terminal-3.14.2-1.fc21,gnome-themes-standard-3.14.2-1.fc21,gnome-user-docs-3.14.2-1.fc21,gtk3-3.14.5-1.fc21,gtksourceview3-3.14.2-1.fc21,gucharmap-3.14.2-1.fc21,gvfs-1.22.2-1.fc21,iagno-3.14.2-1.fc21,libappstream-glib-0.2.7-1.fc21,libgdata-0.16.1-1.fc21,mutter-3.14.2-1.fc21,orca-3.14.2-1.fc21,vinagre-3.14.2-1.fc21,vino-3.14.1-1.fc21,vte291-0.38.2-1.fc21,webkitgtk4-2.6.3-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/aisleriot-3.14.2-1.fc21,appstream-data-21-16.fc21,at-spi2-core-2.14.1-1.fc21,bijiben-3.14.2-1.fc21,cheese-3.14.2-1.fc21,control-center-3.14.2-1.fc21,eog-3.14.2-2.fc21,eog-plugins-3.14.1-1.fc21,epiphany-3.14.2-1.fc21,file-roller-3.14.2-1.fc21,four-in-a-row-3.14.2-1.fc21,gedit-3.14.1-1.fc21,gedit-plugins-3.14.1-1.fc21,glib2-2.42.1-1.fc21,gnome-boxes-3.14.2-1.fc21,gnome-chess-3.14.1-1.fc21,gnome-color-manager-3.14.2-1.fc21,gnome-contacts-3.14.2-1.fc21,gnome-desktop3-3.14.2-1.fc21,gnome-devel-docs-3.14.2-1.fc21,gnome-dictionary-3.14.2-1.fc21,gnome-disk-utility-3.14.0-1.fc21,gnome-klotski-3.14.2-1.fc21,gnome-logs-3.14.2-1.fc21,gnome-maps-3.14.2-1.fc21,gnome-music-3.14.2-1.fc21,gnome-online-accounts-3.14.2-1.fc21,gnome-packagekit-3.14.2-1.fc21,gnome-photos-3.14.2-1.fc21,gnome-robots-3.14.2-1.fc21,gnome-settings-daemon-3.14.2-1.fc21,gnome-shell-3.14.2-1.fc21,gnome-shell-extensions-3.14.2-1.fc21,gnome-software-3.14.2-2.fc21,gnome-sound-recorder-3.14.2-1.fc21,gnome-sudoku-3.14.2-1.fc21,gnome-terminal-3.14.2-1.fc21,gnome-themes-standard-3.14.2-1.fc21,gnome-user-docs-3.14.2-1.fc21,gtk3-3.14.5-1.fc21,gtksourceview3-3.14.2-1.fc21,gucharmap-3.14.2-1.fc21,gvfs-1.22.2-1.fc21,iagno-3.14.2-1.fc21,libappstream-glib-0.2.7-1.fc21,libgdata-0.16.1-1.fc21,mutter-3.14.2-1.fc21,orca-3.14.2-1.fc21,vinagre-3.14.2-1.fc21,vino-3.14.1-1.fc21,vte291-0.38.2-1.fc21,webkitgtk4-2.6.3-1.fc21

Comment 7 Fedora Update System 2014-11-13 18:06:31 UTC
Package aisleriot-3.14.2-1.fc21, appstream-data-21-16.fc21, at-spi2-core-2.14.1-1.fc21, bijiben-3.14.2-1.fc21, cheese-3.14.2-1.fc21, control-center-3.14.2-1.fc21, eog-3.14.2-2.fc21, eog-plugins-3.14.1-1.fc21, epiphany-3.14.2-1.fc21, file-roller-3.14.2-1.fc21, four-in-a-row-3.14.2-1.fc21, gedit-3.14.1-1.fc21, gedit-plugins-3.14.1-1.fc21, glib2-2.42.1-1.fc21, gnome-boxes-3.14.2-1.fc21, gnome-chess-3.14.1-1.fc21, gnome-color-manager-3.14.2-1.fc21, gnome-contacts-3.14.2-1.fc21, gnome-desktop3-3.14.2-1.fc21, gnome-devel-docs-3.14.2-1.fc21, gnome-dictionary-3.14.2-1.fc21, gnome-disk-utility-3.14.0-1.fc21, gnome-klotski-3.14.2-1.fc21, gnome-logs-3.14.2-1.fc21, gnome-maps-3.14.2-1.fc21, gnome-music-3.14.2-1.fc21, gnome-online-accounts-3.14.2-1.fc21, gnome-packagekit-3.14.2-1.fc21, gnome-photos-3.14.2-1.fc21, gnome-robots-3.14.2-1.fc21, gnome-settings-daemon-3.14.2-1.fc21, gnome-shell-3.14.2-1.fc21, gnome-shell-extensions-3.14.2-1.fc21, gnome-software-3.14.2-2.fc21, gnome-sound-recorder-3.14.2-1.fc21, gnome-sudoku-3.14.2-1.fc21, gnome-terminal-3.14.2-1.fc21, gnome-themes-standard-3.14.2-1.fc21, gnome-user-docs-3.14.2-1.fc21, gtk3-3.14.5-1.fc21, gtksourceview3-3.14.2-1.fc21, gucharmap-3.14.2-1.fc21, gvfs-1.22.2-1.fc21, iagno-3.14.2-1.fc21, libappstream-glib-0.2.7-1.fc21, libgdata-0.16.1-1.fc21, mutter-3.14.2-1.fc21, orca-3.14.2-1.fc21, vinagre-3.14.2-1.fc21, vino-3.14.1-1.fc21, vte291-0.38.2-1.fc21, webkitgtk4-2.6.3-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing aisleriot-3.14.2-1.fc21 appstream-data-21-16.fc21 at-spi2-core-2.14.1-1.fc21 bijiben-3.14.2-1.fc21 cheese-3.14.2-1.fc21 control-center-3.14.2-1.fc21 eog-3.14.2-2.fc21 eog-plugins-3.14.1-1.fc21 epiphany-3.14.2-1.fc21 file-roller-3.14.2-1.fc21 four-in-a-row-3.14.2-1.fc21 gedit-3.14.1-1.fc21 gedit-plugins-3.14.1-1.fc21 glib2-2.42.1-1.fc21 gnome-boxes-3.14.2-1.fc21 gnome-chess-3.14.1-1.fc21 gnome-color-manager-3.14.2-1.fc21 gnome-contacts-3.14.2-1.fc21 gnome-desktop3-3.14.2-1.fc21 gnome-devel-docs-3.14.2-1.fc21 gnome-dictionary-3.14.2-1.fc21 gnome-disk-utility-3.14.0-1.fc21 gnome-klotski-3.14.2-1.fc21 gnome-logs-3.14.2-1.fc21 gnome-maps-3.14.2-1.fc21 gnome-music-3.14.2-1.fc21 gnome-online-accounts-3.14.2-1.fc21 gnome-packagekit-3.14.2-1.fc21 gnome-photos-3.14.2-1.fc21 gnome-robots-3.14.2-1.fc21 gnome-settings-daemon-3.14.2-1.fc21 gnome-shell-3.14.2-1.fc21 gnome-shell-extensions-3.14.2-1.fc21 gnome-software-3.14.2-2.fc21 gnome-sound-recorder-3.14.2-1.fc21 gnome-sudoku-3.14.2-1.fc21 gnome-terminal-3.14.2-1.fc21 gnome-themes-standard-3.14.2-1.fc21 gnome-user-docs-3.14.2-1.fc21 gtk3-3.14.5-1.fc21 gtksourceview3-3.14.2-1.fc21 gucharmap-3.14.2-1.fc21 gvfs-1.22.2-1.fc21 iagno-3.14.2-1.fc21 libappstream-glib-0.2.7-1.fc21 libgdata-0.16.1-1.fc21 mutter-3.14.2-1.fc21 orca-3.14.2-1.fc21 vinagre-3.14.2-1.fc21 vino-3.14.1-1.fc21 vte291-0.38.2-1.fc21 webkitgtk4-2.6.3-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-14803/aisleriot-3.14.2-1.fc21,appstream-data-21-16.fc21,at-spi2-core-2.14.1-1.fc21,bijiben-3.14.2-1.fc21,cheese-3.14.2-1.fc21,control-center-3.14.2-1.fc21,eog-3.14.2-2.fc21,eog-plugins-3.14.1-1.fc21,epiphany-3.14.2-1.fc21,file-roller-3.14.2-1.fc21,four-in-a-row-3.14.2-1.fc21,gedit-3.14.1-1.fc21,gedit-plugins-3.14.1-1.fc21,glib2-2.42.1-1.fc21,gnome-boxes-3.14.2-1.fc21,gnome-chess-3.14.1-1.fc21,gnome-color-manager-3.14.2-1.fc21,gnome-contacts-3.14.2-1.fc21,gnome-desktop3-3.14.2-1.fc21,gnome-devel-docs-3.14.2-1.fc21,gnome-dictionary-3.14.2-1.fc21,gnome-disk-utility-3.14.0-1.fc21,gnome-klotski-3.14.2-1.fc21,gnome-logs-3.14.2-1.fc21,gnome-maps-3.14.2-1.fc21,gnome-music-3.14.2-1.fc21,gnome-online-accounts-3.14.2-1.fc21,gnome-packagekit-3.14.2-1.fc21,gnome-photos-3.14.2-1.fc21,gnome-robots-3.14.2-1.fc21,gnome-settings-daemon-3.14.2-1.fc21,gnome-shell-3.14.2-1.fc21,gnome-shell-extensions-3.14.2-1.fc21,gnome-software-3.14.2-2.fc21,gnome-sound-recorder-3.14.2-1.fc21,gnome-sudoku-3.14.2-1.fc21,gnome-terminal-3.14.2-1.fc21,gnome-themes-standard-3.14.2-1.fc21,gnome-user-docs-3.14.2-1.fc21,gtk3-3.14.5-1.fc21,gtksourceview3-3.14.2-1.fc21,gucharmap-3.14.2-1.fc21,gvfs-1.22.2-1.fc21,iagno-3.14.2-1.fc21,libappstream-glib-0.2.7-1.fc21,libgdata-0.16.1-1.fc21,mutter-3.14.2-1.fc21,orca-3.14.2-1.fc21,vinagre-3.14.2-1.fc21,vino-3.14.1-1.fc21,vte291-0.38.2-1.fc21,webkitgtk4-2.6.3-1.fc21
then log in and leave karma (feedback).

Comment 8 Jörg BUCHMANN 2014-11-14 11:52:38 UTC
Hi,

Thanks for you help. I have updated following your recommendations and it creates now the each note on the owncloud server BUT THE NOTES ARE EMPTY (there is just the title appearing in the head bar of the window). I tried to update the notes but that didn't change anything.

Comment 9 Jörg BUCHMANN 2014-11-14 12:12:29 UTC
Hi guys,

Have tried it from another Fedora 21 virtual machine and from that one, I could change the note. And miracle, now I can change the note from the original VM as well! Very strange... So we can eventually consider this bug closed??

Comment 10 Pierre-Yves Luyten 2014-11-14 12:35:31 UTC
(In reply to Jörg BUCHMANN from comment #9)

> Have tried it from another Fedora 21 virtual machine and from that one, I
> could change the note. And miracle, now I can change the note from the
> original VM as well! Very strange... So we can eventually consider this bug
> closed??

Thanks much for the testing, quite appreciated. Indeed from the original bug report and the code change, there is no reason for Notes folder not to be created, thus Notes themselves should be.


The "empty notes" point you raised in comment 8 is still embarassing. Did you check actual files content or just opened notes from the application? You might try deleting Notes folder to ensure you cannot reproduce such bug.


Also, upstream bug has a feedback from an Arch user which still has issue after the update, which I cannot explain nor reproduce yet.

Comment 11 Jörg BUCHMANN 2014-11-14 14:18:43 UTC
In fact, the .txt files in the Notes folder were empty. I had checked with gedit at my first attempt above, but forgot to tell.

Following your idea, I have deleted the Notes folder with its files and tried it again. I have the same phenomenon. :( Then I have tried to fill the empty notes in gnome notes again and no luck. After a certain time, just after having written this paragraph I am able to modify/alter the empty notes and my changes are saved. Strange. This time, I did everything from the same VM. Hope this will help you.

Comment 12 Jörg BUCHMANN 2014-11-14 14:21:30 UTC
By the way, we are using the latest version of OwnCloud Server 7 and an up to date version of Fedora 21 beta.

Comment 13 Fedora Update System 2014-11-15 09:11:43 UTC
aisleriot-3.14.2-1.fc21, appstream-data-21-16.fc21, at-spi2-core-2.14.1-1.fc21, bijiben-3.14.2-1.fc21, cheese-3.14.2-1.fc21, control-center-3.14.2-1.fc21, eog-3.14.2-2.fc21, eog-plugins-3.14.1-1.fc21, epiphany-3.14.2-1.fc21, file-roller-3.14.2-1.fc21, four-in-a-row-3.14.2-1.fc21, gedit-3.14.1-1.fc21, gedit-plugins-3.14.1-1.fc21, glib2-2.42.1-1.fc21, gnome-boxes-3.14.2-1.fc21, gnome-chess-3.14.1-1.fc21, gnome-color-manager-3.14.2-1.fc21, gnome-contacts-3.14.2-1.fc21, gnome-desktop3-3.14.2-1.fc21, gnome-devel-docs-3.14.2-1.fc21, gnome-dictionary-3.14.2-1.fc21, gnome-disk-utility-3.14.0-1.fc21, gnome-klotski-3.14.2-1.fc21, gnome-logs-3.14.2-1.fc21, gnome-maps-3.14.2-1.fc21, gnome-music-3.14.2-1.fc21, gnome-online-accounts-3.14.2-1.fc21, gnome-packagekit-3.14.2-1.fc21, gnome-photos-3.14.2-1.fc21, gnome-robots-3.14.2-1.fc21, gnome-settings-daemon-3.14.2-1.fc21, gnome-shell-3.14.2-1.fc21, gnome-shell-extensions-3.14.2-1.fc21, gnome-software-3.14.2-2.fc21, gnome-sound-recorder-3.14.2-1.fc21, gnome-sudoku-3.14.2-1.fc21, gnome-terminal-3.14.2-1.fc21, gnome-themes-standard-3.14.2-1.fc21, gnome-user-docs-3.14.2-1.fc21, gtk3-3.14.5-1.fc21, gtksourceview3-3.14.2-1.fc21, gucharmap-3.14.2-1.fc21, gvfs-1.22.2-1.fc21, iagno-3.14.2-1.fc21, libappstream-glib-0.2.7-1.fc21, libgdata-0.16.1-1.fc21, mutter-3.14.2-1.fc21, orca-3.14.2-1.fc21, vinagre-3.14.2-1.fc21, vino-3.14.1-1.fc21, vte291-0.38.2-1.fc21, webkitgtk4-2.6.3-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Adam Williamson (Fedora) 2014-11-21 17:01:16 UTC
Jorg: in any case it'd be best to file a new bug if you still have an issue creating new notes which can be reproduced. This bug report was for the issue of the Notes folder not being created if necessary, whatever you're hitting now must be something different. Thanks!


Note You need to log in before you can comment on or make changes to this bug.