Bug 116201 - /var/named/chroot/dev/random has wrong minor number
Summary: /var/named/chroot/dev/random has wrong minor number
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: bind   
(Show other bugs)
Version: 1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-18 23:54 UTC by Graham King
Modified: 2012-10-05 09:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 22:22:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Graham King 2004-02-18 23:54:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.11 (X11; Linux i686; U;) Gecko/20030417

Description of problem:
crw-r--r--    1 root     root       1,   8 Sep 15 14:40 /dev/random
crw-r-----    1 root     named      1,   9 Feb  2 13:09
/var/named/chroot/dev/random

service named start gives syslog message:

 named[9279]: could not open entropy source /dev/random: permission denied


Version-Release number of selected component (if applicable):
bind-9.2.2.P3-9
bind-chroot-9.2.2.P3-9   bind-9.2.2.P3-9

How reproducible:
Always

Steps to Reproduce:
1.service named start
2.view syslog (might need debug level syslog config)
3.
    

Additional info:

Comment 1 Graham King 2004-02-19 00:00:02 UTC
Adding a new /var/named/chroot/dev/random with minor number 8 (using
mknod) does not get rid of the syslog message at named startup.


Comment 2 Daniel Walsh 2004-03-25 20:13:42 UTC
/dev/random has the wrong owenership it should be
crw-r-----  1 root named 1, 9 Mar 24 09:46 random


Comment 3 Daniel Walsh 2004-03-25 20:14:19 UTC
Looks right in bind-9.2.3-9


Comment 4 Graham King 2004-03-26 09:02:57 UTC
dwalsh@redhat.com wrote:
> /dev/random has the wrong owenership it should be
> crw-r-----  1 root named 1, 9 Mar 24 09:46 random

Surely you don't mean that?  Those ownerships and permissions might be
suitable for the __chroot'ed__ dev/random used by named, but not for
/dev/random itself.


Comment 5 Daniel Walsh 2004-03-26 15:26:48 UTC
Yes I meand /var/named/chroot/dev/random.

Sorry about that.

Comment 6 Graham King 2004-07-16 15:35:29 UTC
Apologies for the long delay.  I've recently upgraded to Fedora Core 2
(bind-chroot-9.2.3-13), with the following result:

ls -l /var/named/chroot/dev
total 0
-rw-r-----  1 root named 0 Mar 25  2003 null
-rw-r-----  1 root named 0 Mar 14  2003 random

Ownerships look reasonable.  Permissions might be OK although I would
have expected at least g+w on null.

However, both files are now ordinary files, not devices.  Surely that
can't be right?

Comment 7 Jason Vas Dias 2004-08-30 22:22:28 UTC
This was fixed in bind-9.2.4rc6-6 (Latest version bind-9.2.4rc7-10).

Comment 8 Chimorro 2012-10-05 09:21:10 UTC
(In reply to comment #7)
> This was fixed in bind-9.2.4rc6-6 (Latest version bind-9.2.4rc7-10).

With bind9-9.7.3.df same problem today;

seems solved setting group 'bind' (not worked with 'named')

ll /var/bind9/chroot/dev
total 0
srw-rw-rw- 1 root root    0 Oct  5 09:09 log
crw-rw---- 1 root root 1, 3 Oct  5 02:21 null
crw-rw---- 1 root bind 1, 8 Oct  5 02:21 random


Note You need to log in before you can comment on or make changes to this bug.