Bug 116202 - No Java bindings for subversion
Summary: No Java bindings for subversion
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-18 23:59 UTC by rudi
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 1.1.4-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-13 18:31:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description rudi 2004-02-18 23:59:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
The current subversion packages do not build the Java bindings (javahl).
Having libsvnjavahl.* plus svnjavahl.jar available would make it much
easier to package subclipse, the subversion plugin for Eclipse. Right
now there's no choice but to include the subversion sources, which
of course sucks.


Version-Release number of selected component (if applicable):
subversion-0.37.0-1

How reproducible:
Always

Steps to Reproduce:
1. Install subversion
2. Look for libsvnjavahl and co.

    

Actual Results:  No bindings

Expected Results:  Bindings should be installed (or should be
available through e.g. a
subversion-java subpackage)

Additional info:

I have no clue which standards for spec files would apply to Java
bindings, but I'd be glad to test or (given enough pointers/input)
work on patches.

Comment 1 Joe Orton 2004-02-19 09:10:26 UTC
Well, since we don't ship a JDK, this would mean getting the
Subversion Java bindings working with GCJ.  I doubt anyone has tried
this before.

Comment 2 Joe Orton 2004-02-19 09:37:53 UTC
This doesn't look trivial, it needs someone with Java/GCJ expertise to
get do the legwork upstream first.

Comment 3 rudi 2005-03-07 22:06:16 UTC
This should be doable now:

https://www.redhat.com/archives/fedora-devel-list/2005-February/msg00063.html


Comment 4 Joe Orton 2005-03-08 20:54:41 UTC
Anthony has provided a patch to subversion which fixes this side of
things, but the code is triggering an ecj compiler crash on IA64, it
seems, which will block progress.

Comment 5 Rudi Chiarito 2005-03-24 16:41:25 UTC
Could this be enabled in Raw Hide for all architectures except IA64?
This is simply making it harder to provide SVN support to Eclipse.
At the same time as the ecj bug gets fixed, a subclipse RPM could at
least get some exposure and testing on other platforms. Right now
an architecture that very few people use is preventing that from
happening.

Have I been melodramatic enough?

Comment 6 Joe Orton 2005-04-13 18:30:51 UTC
Yes, seems reasonable; done in Raw Hide on everything except ia64. 

bug 154700 filed for the ecj issue on ia64.

Comment 7 Joe Orton 2005-04-13 18:31:27 UTC
Yes, seems reasonable; done in Raw Hide on everything except ia64. 

bug 154700 filed for the ecj issue on ia64.


Note You need to log in before you can comment on or make changes to this bug.