Bug 1162080 - "-numa node" option cause windows guest can not online hot-added CPUs
Summary: "-numa node" option cause windows guest can not online hot-added CPUs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.1
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Igor Mammedov
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1188584 (view as bug list)
Depends On:
Blocks: 1188200 1191384 1191385
TreeView+ depends on / blocked
 
Reported: 2014-11-10 08:59 UTC by FuXiangChun
Modified: 2015-12-04 16:20 UTC (History)
10 users (show)

Fixed In Version: qemu-kvm-rhev-2.2.0-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1191384 1191385 (view as bug list)
Environment:
Last Closed: 2015-12-04 16:20:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description FuXiangChun 2014-11-10 08:59:28 UTC
Description of problem:
Boot win2008r2 & win2012r2 guest with "-numa node", then Hotplug vCPU to guest via QMP.  can not find hot-added cpus via Task Manager inside guest.  

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.1.2-6.el7.x86_64
3.10.0-196.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. /usr/libexec/qemu-kvm -name windows  -m 4G -smp 1,cores=1,threads=1,sockets=64,maxcpus=240 -numa node ....

2. Hotplug vCPU to guest via QMP

3. check Task Manager inside guest

Actual results:
can not find Hot-added cpus

Expected results:
should find at least 8.

Additional info:
1. As 968811 is fixed. so for RHEL7.1 guest didn't hit this issue.

2. QE tested qemu-kvm-1.5.3-60.el7.x86_64 and qemu-kvm-1.5.3-77.el7.x86_64, Both of them hit this issue. so it is not regression bug.

3. can find Hot-added CPUs in device management inside guest(no online).

4. As linux guest didn't hit this issue. only windows guest has this issue. so QE is not sure if it is a qemu-kvm's bug.

Comment 2 Igor Mammedov 2014-11-10 10:00:46 UTC
I've also reproduced it, hot-added CPUs are actually seen by guest in device manager but not onlined/used by it until reboot.

Comment 3 Igor Mammedov 2015-02-03 10:53:16 UTC
*** Bug 1188584 has been marked as a duplicate of this bug. ***

Comment 4 Igor Mammedov 2015-02-03 10:54:32 UTC
fixed upstream: v2.2.0-rc2-30-gdd0247e
[dd0247e09a542d2a7ba6e390c70b5616edb9ec56] pc: acpi: mark all possible CPUs as enabled in SRAT

Comment 5 biaoxiangye 2015-02-06 01:52:27 UTC
good job

Comment 8 huiqingding 2015-03-24 03:12:25 UTC
Reproduce this bug using the following version:
qemu-kvm-rhev-2.1.2-23.el7.x86_64
kernel-3.10.0-232.el7.x86_64

Test steps:
1. boot a win2012r2 guest with 1 vcpu
/usr/libexec/qemu-kvm -name windows  -m 4G -smp 1,cores=1,threads=1,sockets=64,maxcpus=240 -numa node ....

2. Hotplug vCPU to guest via QMP
{"execute": "qmp_capabilities"}
{"return": {}}
{ "execute": "cpu-add", "arguments": { "id": 1  }}
{"return": {}}
{ "execute": "cpu-add", "arguments": { "id":2}}
{"return": {}}
{ "execute": "cpu-add", "arguments": { "id":3}}
{"return": {}}
{ "execute": "cpu-add", "arguments": { "id":4}}
{"return": {}}
{ "execute": "cpu-add", "arguments": { "id":5}}
{"return": {}}

3. check Task Manager inside guest

Actual results:
can not find Hot-added cpus.

Comment 9 huiqingding 2015-03-24 03:16:24 UTC
Test this bug using the following version:
qemu-kvm-rhev-2.2.0-8.el7.x86_64
kernel-3.10.0-232.el7.x86_64

Tested guest:
win2012r2, win2008r2-64

Test steps:
1. boot a win2012r2/win2008r2-64 guest with 1 vcpu
/usr/libexec/qemu-kvm -name windows  -m 4G -smp 1,cores=1,threads=1,sockets=64,maxcpus=240 -numa node ....

2. Hotplug vCPU to guest via QMP
{"execute": "qmp_capabilities"}
{"return": {}}
{ "execute": "cpu-add", "arguments": { "id": 1  }}
{"return": {}}
{ "execute": "cpu-add", "arguments": { "id": 2  }}
{"return": {}}
{ "execute": "cpu-add", "arguments": { "id": 3  }}
{"return": {}}
{ "execute": "cpu-add", "arguments": { "id": 4  }}
{"return": {}}
{ "execute": "cpu-add", "arguments": { "id": 5  }}
{"return": {}}

3. check Task Manager inside guest

Actual results:
can find 6 cpus in "Task Manager".

Comment 11 huiqingding 2015-06-24 05:42:43 UTC
Based on Comment 9, set this bug to VERIFIED.

Best regards,
Huiqing

Comment 13 errata-xmlrpc 2015-12-04 16:20:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.