Bug 11621 - Man pages displaying <AD> at end of lines
Man pages displaying <AD> at end of lines
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-24 03:10 EDT by Stephen Rasku
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-29 15:26:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Rasku 2000-05-24 03:10:10 EDT
I am getting <AD> displayed at the end of lines for a lot of man pages.  It
will occur on a text console or on a Konsole under KDE and it displays in
the same place on both.  Here's an example, man rwhod:



RWHOD(8)                    System Manager's Manual
RWHOD(8)

NAME
     rwhod - system status server

SYNOPSIS
     rwhod [-bpa]

DESCRIPTION
     Rwhod is the server which maintains the database used by the rwho(1)
and
     ruptime(1) programs.  Its operation is predicated on the ability to
     broadcast messages on a network.

     Rwhod operates as both a producer and consumer of status information.
As
     a producer of information it periodically queries the state of the
system
     and constructs status messages which are broadcast on a network.  As a
     consumer of information, it listens for other rwhod servers' status
mes<AD>
     sages, validating them, then recording them in a collection of files
lo<AD>
     cated in the directory
/var/spool/rwho.
Comment 1 Pekka Savola 2000-05-25 11:06:59 EDT
'export LESSCHARSET=latin1' fixes this problem.
Comment 2 SB 2000-05-29 15:26:59 EDT
Setting the charset is not a solution for all users.  You need to edit your
/etc/man.config and change this line:
PAGER           /usr/bin/less -is

to

PAGER           /usr/bin/less -isr

That solves the problem. Here's an explanation in less man page:
-r or --raw-control-chars
       Causes  "raw"  control  characters  to be displayed.  The default is to
       display control characters using the caret notation; for example, a
       control-A (octal 001) is  displayed  as  "^A".   Warning: when  the  -r
       option is used, less cannot keep track of the actual appearance of the
       screen (since this depends on how the screen responds to each type of
       control character).  Thus, various display problems may result, such
       as long lines being split in the wrong place.

I've never experienced any problems the man page indicates so I doubt you will
either.

-Stan Bubrouski
Comment 3 Bernhard Rosenkraenzer 2000-08-04 06:18:53 EDT
Thanks, fixed in 1.5h1-8

Note You need to log in before you can comment on or make changes to this bug.