Bug 116211 - yum cannot update headers
yum cannot update headers
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-18 21:59 EST by Michael Dale Long
Modified: 2014-01-21 17:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-19 05:22:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Dale Long 2004-02-18 21:59:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5)
Gecko/20031007

Description of problem:
"yum update" and "yum check-update" both fail on with an error
complaining about a corrupt header on the server.  The exact error
message is given below.

Version-Release number of selected component (if applicable):
yum-2.0.4.20040103-1

How reproducible:
Always

Steps to Reproduce:
1.Run "yum update" or "yum check-update"
2.
3.
    

Actual Results:  An error message is given and update is halted.

Expected Results:  Update (or check-update) should have finished
successfully.

Additional info:

[root@norfair root]# yum check-update
Gathering header information file(s) from server(s)
Server: Fedora Core 1.90 - Development Tree
Finding updated packages
Downloading needed headers
Damaged Header
/var/cache/yum/development/headers/kernel-source-0-2.6.2-1.87.i386.hdr
kernel-source-0-2.6.2-1.8 100% |=========================| 176 kB    05:01
Damaged Header
/var/cache/yum/development/headers/kernel-source-0-2.6.2-1.87.i386.hdr
retrygrab() failed for:
 
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386//headers/kernel-source-0-2.6.2-1.87.i386.hdr
  Executing failover method
failover: out of servers to try
Error getting file
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386//headers/kernel-source-0-2.6.2-1.87.i386.hdr
[Errno 7] HTTP Error (CannotSendRequest):

-----------
I also get this sometimes:

[root@norfair root]# yum check-update
Gathering header information file(s) from server(s)
Server: Fedora Core 1.90 - Development Tree
Damaged or Bad header.info from Fedora Core 1.90 - Development Tree
This is probably because of a downed server or an invalid header.info
on a repository.
Comment 1 Seth Vidal 2004-02-18 22:12:41 EST
Hi,
 You're using download.fedora.redhat.com - it's WAY overloaded and a
touch odd. you're getting errors b/c it is overloaded. use a mirror
and this problem should go away.

Note You need to log in before you can comment on or make changes to this bug.