Bug 116212 - Evolution GLib errors on startup
Evolution GLib errors on startup
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-18 22:33 EST by Carl Gherardi
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-17 16:11:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl Gherardi 2004-02-18 22:33:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040115 Epiphany/1.0.7

Description of problem:
On startup from a terminal evolution generates some GLib errors.

(evolution:3619): GLib-CRITICAL **: file gstrfuncs.c: line 2129
(g_strsplit): assertion `string != NULL' failed

(evolution:3619): GLib-CRITICAL **: file gstrfuncs.c: line 2241
(g_strjoinv): assertion `str_array != NULL' failed

I'm also experiencing multiple crashes a day - will report segfaults
as another bug.

Version-Release number of selected component (if applicable):
evolution-1.5.3-1

How reproducible:
Always

Steps to Reproduce:
1. Start evlution from the terminal
2. Watch errors

Expected Results:  No errors only debug info like:

pipe_to_sa /bin/sh -c spamassassin --version 
test if spamd is running (port -1)
pipe_to_sa spamc -x 
use spamd 1 at port -1
pipe_to_sa spamc -c

Additional info:

Using Fedora 1.90 + updates (Upgraded from Fedora Core 1)
Comment 1 George Karabin 2004-03-05 12:26:51 EST
This has been fixed by a more recent glib. I've got glib2-2.3.5-1 out
of the development tree, which fixed it for me.
Comment 2 Dave Malcolm 2004-05-17 16:11:20 EDT
This looks like it was an Evolution bug; I can't reproduce this in the
latest build of Evolution (1.5.7), so I'm going to mark this as WORKSFORME

Note You need to log in before you can comment on or make changes to this bug.