Bug 1162245 - "KVM: unknown exit, hardware reason 10080000050" when trying multipath
Summary: "KVM: unknown exit, hardware reason 10080000050" when trying multipath
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: qemu
Version: 20
Hardware: ppc64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fedora Virtualization Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2014-11-10 16:18 UTC by Jaromír Cápík
Modified: 2016-02-01 02:00 UTC (History)
11 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-11-10 17:00:15 UTC


Attachments (Terms of Use)

Description Jaromír Cápík 2014-11-10 16:18:04 UTC
Description of problem:
When trying a multipath scenario with the following command ...

qemu-system-ppc64 -enable-kvm -M pseries -cpu POWER7 \
       -smp cores=4,threads=4 -m 24G -nographic -nodefaults -monitor stdio -serial pty \
       -device spapr-vlan,netdev=net1,mac=7E:AD:CD:AD:DE:B1 -netdev bridge,br=br0,id=net1 \
       -device virtio-scsi-pci,id=scsi \
       -drive if=none,id=hda,file=/home/qemu/test.img,serial=0001 \
       -device scsi-hd,drive=hda \
       -drive if=none,id=hdb,file=/home/qemu/test.img,serial=0001 \
       -device scsi-hd,drive=hdb \
       -cdrom iso/Fedora-Server-DVD-ppc64-21_Beta.iso \
       -boot order=d

... I always get the following error ...

QEMU 2.1.0 monitor - type 'help' for more information
(qemu) char device redirected to /dev/pts/6 (label serial0)
KVM: unknown exit, hardware reason 10080000050
NIP c0000000004a1188   LR d000000004a805a0 CTR c0000000004a1100 XER 0000000000000000
MSR 8000000000009032 HID0 0000000000000000  HF 0000000000000000 idx 1
TB 00000000 00000000 DECR 00000000
GPR00 d000000004a20304 c00000059616ee60 c0000000015108e8 0000000000000002
GPR04 0000000000010050 0000000000000003 c0000005a338a6e0 c0000000013b08e8
GPR08 d000080000000000 0000000000000002 d000080000010050 d000000004a81fc0
GPR12 c0000000004a1100 c00000000fdc0900 c000000593fd0000 0000000000000024
GPR16 0000000000000000 0000000000000000 c000000000bf32e8 c000000000bf3380
GPR20 c000000000b78d48 c000000000b78b90 c000000000bf3230 c0000005967ae168
GPR24 c0000000014e60d0 c000000595f01140 c0000005967ae034 c0000005967ae050
GPR28 0000000000000001 0000000000000001 0000000000000000 c000000594b45000
CR 24022022  [ E  G  -  E  E  -  E  E  ]             RES ffffffffffffffff
FPR00 0000000000000000 0000000000000000 0000000000000000 0000000000000000
FPR04 0000000000000000 0000000000000000 2f7573722f6c6962 2f73797374656d2f
FPR08 6365732d76696f2d 2d6e65742d657468 0000000000000000 0000000000000000
FPR12 0000000000000001 0000000000000000 0000000000000000 0000000000000000
FPR16 0000000000000000 0000000000000000 0000000000000000 0000000000000000
FPR20 0000000000000000 0000000000000000 0000000000000000 0000000000000000
FPR24 0000000000000000 0000000000000000 0000000000000000 0000000000000000
FPR28 0000000000000000 0000000000000000 0000000000000000 0000000000000000
FPSCR 0000000000000000
 SRR0 c0000000004a1184  SRR1 8000000000009032    PVR 00000000004a0201 VRSAVE 0000000000000000
SPRG0 0000000000000000 SPRG1 c00000000fdc0900  SPRG2 c00000000fdc0900  SPRG3 0000000000000001
SPRG4 0000000000000000 SPRG5 0000000000000000  SPRG6 0000000000000000  SPRG7 0000000000000000
 CFAR 0000000000000000
 SDR1 000000000000000a   DAR d000080000010050  DSISR 0000000002000000

... and it always happens when the guest kernel prints the following ...

[  OK  ] Started dracut pre-udev hook.
         Starting udev Kernel Device Manager...
[    7.348385] systemd-udevd[512]: starting version 215
[  OK  ] Started udev Kernel Device Manager.
         Starting dracut pre-trigger hook...
[    7.505949] virtio-pci 0000:00:00.0: enabling device (0100 -> 0103)
[    7.629989] ibmvscsi 71000002: SRP_VERSION: 16.a
[    7.630377] scsi host0: IBM POWER Virtual SCSI Adapter 1.5.9
[    7.631283] ibmvscsi 71000002: partner initialization complete
[    7.631679] ibmvscsi 71000002: host srp version: 16.a, host partition qemu (0), OS 2, max io 2097152
[    7.632173] ibmvscsi 71000002: sent SRP login
[    7.632454] ibmvscsi 71000002: SRP_LOGIN succeeded
[    7.643648] ibmveth 71000003 (unnamed net_device) (uninitialized): unable to change checksum offload settings. 1 rc=-2 ret_attr=71000003
[    7.645931] scsi 0:0:2:0: CD-ROM            QEMU     QEMU CD-ROM      2.1. PQ: 0 ANSI: 5
[    7.656121] scsi host1: Virtio SCSI HBA


Version-Release number of selected component (if applicable):
qemu-2.1.0-2.fc22.ppc64
kernel-3.14.5-200.fc20.ppc64p7

How reproducible:
always

Comment 1 Jaromír Cápík 2014-11-10 17:00:15 UTC
Tested with kernel-3.16.7-200.fc20.ppc64 and it works correctly. Closing.


Note You need to log in before you can comment on or make changes to this bug.