Bug 1162381 - update targetd in RHEL 7
Summary: update targetd in RHEL 7
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: targetd   
(Show other bugs)
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Tony Asleson
QA Contact: Martin Hoyer
Milan Navratil
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1074659 1385242
TreeView+ depends on / blocked
 
Reported: 2014-11-11 01:04 UTC by Andy Grover
Modified: 2017-08-01 20:43 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
_targetd_ rebased to version 0.8.6 The _targetd_ packages have been upgraded to upstream version 0.8.6, which provides a number of bug fixes and enhancements over the previous version. Notably, the *targetd* service now runs on either Python 2 or Python 3 run time, and the following APIs have been added: *initiator_list*, *access_group_list*, *access_group_create*, *access_group_destroy*, *access_group_init_add*, *access_group_init_del*, *access_group_map_list*, *access_group_map_create*, and *access_group_map_destroy*. Notable bug fixes include: * *targetd* is now compliant with JSON-RPC response version 2.0. * the *export_create* API can now be used to map the same LUN to multiple initiators. * *targetd* now ensures that SSL certificates are present at start-up.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 20:43:39 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1982 normal SHIPPED_LIVE targetd bug fix and enhancement update 2017-08-01 18:31:11 UTC

Description Andy Grover 2014-11-11 01:04:34 UTC
targetd 0.7.2 has improved support for thinpools and also fixes bug 1074659. It also needs some interface changes to function with libstoragemgmt 1.0.

Comment 2 Tom Coughlan 2014-12-23 20:38:58 UTC
moving this to 7.2

Comment 8 Martin Hoyer 2017-04-28 12:55:37 UTC
Tested with targetd-0.8.5-1.el7
No regression found.

Comment 12 errata-xmlrpc 2017-08-01 20:43:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1982


Note You need to log in before you can comment on or make changes to this bug.