Bug 1162416 - Incorrect name of ovirt-node packages
Summary: Incorrect name of ovirt-node packages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-11-11 04:14 UTC by cshao
Modified: 2016-02-10 20:09 UTC (History)
14 users (show)

Fixed In Version: ovirt-node-3.2.1-5.el6 ovirt-node-3.2.1-5.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 21:05:44 UTC
oVirt Team: Node


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC

Description cshao 2014-11-11 04:14:59 UTC
Description of problem:
The right name for ovirt-node package should be like this:
ovirt-node-3.0.1-19.el6.21
But now the virt-node package show as below, this is not recommended.
Here need to make ovirt-node package name in format.

# rpm -qa | grep ovirt-node
ovirt-node-plugin-vdsm-0.2.0-11.el6ev.noarch
ovirt-node-plugin-rhn-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch
ovirt-node-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch
ovirt-node-plugin-hosted-engine-0.2.0-2.0.el6ev.x86_64
ovirt-node-plugin-cim-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch
ovirt-node-plugin-snmp-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch
ovirt-node-branding-rhev-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch
ovirt-node-selinux-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch


Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.6-20141107.0.iso
ovirt-node-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch

How reproducible:
100%
QA Whiteboard: package
Not regression bug.

Steps to Reproduce:
1. Install the hypervisor.
2. Check the ovirt-node package version info.
3.

Actual results:
Incorrect name for ovirt-node package

Expected results:
The right name for ovirt-node package should be like this:
ovirt-node-3.0.1-19.el6.21


Additional info:
The same issue occurs on rhev-hypervisor7-7.0-20141107.0 
ovirt-node-3.1.0-0.25.20141107gitf6dc7b9.el7.noarch

# rpm -qa | grep ovirt-node
ovirt-node-selinux-3.1.0-0.25.20141107gitf6dc7b9.el7.noarch
ovirt-node-plugin-hosted-engine-0.2.0-2.0.el7.x86_64
ovirt-node-plugin-cim-3.1.0-0.25.20141107gitf6dc7b9.el7.noarch
ovirt-node-plugin-rhn-3.1.0-0.25.20141107gitf6dc7b9.el7.noarch
ovirt-node-3.1.0-0.25.20141107gitf6dc7b9.el7.noarch
ovirt-node-plugin-vdsm-0.2.0-10.el7ev.noarch
ovirt-node-branding-rhev-3.1.0-0.25.20141107gitf6dc7b9.el7.noarch
ovirt-node-plugin-snmp-3.1.0-0.25.20141107gitf6dc7b9.el7.noarch

Comment 1 Ying Cui 2014-11-11 05:09:36 UTC
Let's consider fix this bug in rhev 3.5 beta for good user experience.

Comment 2 Fabian Deutsch 2014-11-11 11:20:17 UTC
The name will be adjusted soon.

Comment 3 Ying Cui 2014-12-24 11:22:46 UTC
This ovirt-node version info is displayed that in description, that is not professional for enterprise level product, especially the RHEVH GA version.

So this must consider as RC and GA blocker.

Comment 4 Ying Cui 2014-12-24 11:24:04 UTC
Due to rhevh 3.5 is in RC phase now, so I make this bug to Urgent to get more attention.

Comment 6 Michal Skrivanek 2015-01-13 08:19:45 UTC
how could this be a blocker to a release??

Comment 7 Gil Klein 2015-01-13 08:25:41 UTC
Michal, please see comment #3

Comment 8 Fabian Deutsch 2015-01-13 16:25:59 UTC
ovirt-node-3.2.1 will be used as a base for 3.5.

This has also just been posted on upstream.

Comment 13 cshao 2015-01-20 01:21:06 UTC
Test version:
rhev-hypervisor6-6.6-20150119.0.1.iso
ovirt-node-3.2.1-5.el6.noarch

Test result:
# rpm -qa | grep ovirt-node
ovirt-node-plugin-snmp-3.2.1-5.el6.noarch
ovirt-node-branding-rhev-3.2.1-5.el6.noarch
ovirt-node-plugin-rhn-3.2.1-5.el6.noarch
ovirt-node-3.2.1-5.el6.noarch
ovirt-node-plugin-cim-3.2.1-5.el6.noarch
ovirt-node-selinux-3.2.1-5.el6.noarch
ovirt-node-plugin-vdsm-0.2.0-18.el6ev.noarch


Test version:
rhev-hypervisor7-7.0-20150119.0.1.iso
ovirt-node-3.2.1-5.el7.noarch

Test result:
# rpm -qa | grep ovirt-node
ovirt-node-selinux-3.2.1-5.el7.noarch
ovirt-node-plugin-rhn-3.2.1-5.el7.noarch
ovirt-node-3.2.1-5.el7.noarch
ovirt-node-plugin-vdsm-0.2.0-18.el7ev.noarch
ovirt-node-plugin-snmp-3.2.1-5.el7.noarch
ovirt-node-branding-rhev-3.2.1-5.el7.noarch
ovirt-node-plugin-cim-3.2.1-5.el7.noarch


ovirt-node version info can display correctly, so the bug has been fixed with above build.

Comment 14 cshao 2015-01-20 01:59:26 UTC
Verify this bug according #13

Comment 16 errata-xmlrpc 2015-02-11 21:05:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.