Bug 116252 - I have the canconfirm bit set, but I can't confirm bugs.
I have the canconfirm bit set, but I can't confirm bugs.
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.17
All Linux
medium Severity high (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-19 10:42 EST by Thomas Covello
Modified: 2007-04-18 13:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-29 15:31:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Covello 2004-02-19 10:42:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
Under Preferences->permissions, I see that I have the 'canconfirm' bit
set. I cannot, however, confirm bugs.

How reproducible:
Always

Steps to Reproduce:
Go to Preferences->Permissions.
Observe.
Try to confirm a NEW bug.
The option to do so isn't ever available.
Comment 1 Thomas Covello 2004-02-19 10:44:07 EST
I can only change my own bugs.
Comment 2 David Lawrence 2004-03-29 15:31:10 EST
this is expected behaviour. The canconfirm permission is a left over
from the upstream bugzilla source which initially puts new bugs in a
UNCONFIRMED state. People with the canconfirm perm can put bugs from
UNCONFIRMED to NEW. We instead put them staight into a NEW state. 
After that only people with editbugs perms or the reporter can edit
the report (minus adding a comment or adding self to cc list). I have
removed the canconfirm permission to avoid confusion since this is the
first time the topic has come up.

Note You need to log in before you can comment on or make changes to this bug.