Bug 1162767 - DHT: Rebalance- Rebalance process crash after remove-brick
Summary: DHT: Rebalance- Rebalance process crash after remove-brick
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: 3.5.3
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1146906 1159280
Blocks: 1147095 1159571 1184191
TreeView+ depends on / blocked
 
Reported: 2014-11-11 16:31 UTC by Nithya Balachandran
Modified: 2015-06-03 21:08 UTC (History)
9 users (show)

Fixed In Version: glusterfs-3.5.4
Doc Type: Bug Fix
Doc Text:
Clone Of: 1159280
Environment:
Last Closed: 2015-06-03 21:08:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2014-11-12 04:27:43 UTC
REVIEW: http://review.gluster.org/9099 (Cluster/DHT : Fixed crash due to null deref) posted (#1) for review on release-3.5 by N Balachandran (nbalacha@redhat.com)

Comment 2 Anand Avati 2014-12-04 21:30:12 UTC
COMMIT: http://review.gluster.org/9099 committed in release-3.5 by Niels de Vos (ndevos@redhat.com) 
------
commit 2de7f7c1e8da083d37b3fb4f5004750ae09d9e38
Author: Nithya Balachandran <nbalacha@redhat.com>
Date:   Tue Nov 11 22:06:56 2014 +0530

    Cluster/DHT : Fixed crash due to null deref
    
    A lookup on a linkto file whose trusted.glusterfs.dht.linkto
    xattr points to a subvol that is not part of the volume
    can cause the brick process to segfault due to a null dereference.
    Modified to check for a non-null value before attempting to access
    the variable.
    
    Change-Id: Ie8f9df058f842cfc0c2b52a8f147e557677386fa
    BUG: 1162767
    BUG:1162767
    Signed-off-by: Nithya Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/9034
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: venkatesh somyajulu <vsomyaju@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    (cherry picked from commit 0da374020c17256141fb3971ae792b62097d72df)
    Signed-off-by: Nithya Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/9099
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 3 Niels de Vos 2015-06-03 21:08:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.4, please reopen this bug report.

glusterfs-3.5.4 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.packaging/2
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.