Bug 116277 - could not register the system with RHN ...error says "no route to host" even if proxy settings are configured correctly and "telnet xmlrpc.rhn.redhat.com 443" is successful
could not register the system with RHN ...error says "no route to host" even ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: rhn_register (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-19 12:02 EST by Demosthenes T. Mateo Jr.
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 15:57:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Demosthenes T. Mateo Jr. 2004-02-19 12:02:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Customer is using RHAS 2.1 and wants to register his system with RHN.

We configured his proxy settings using "up2date --configure" and
entered the correct "proxyserver:port" values. We double checked by
using the same proxy settings in mozilla and he confirmed that he can
browse http://rhn.redhat.com.

We executed "up2date" or "rhn_register" to register the system but
failed with an error message which says "no route to host". 

We tried "telnet xmlrpc.rhn.redhat.com 443" and it was successful.

We looked into the file /usr/share/rhn/register/hardware.py and in
line #273 we saw this code:
    s.connect((server, 80))

We changed port 80 to 443 and everything now works!

There is no way to change these settings using any currently available
tool since the port number (80) is hardcoded into hardware.py. 

We assumed that port 80 has been blocked but port 443 is open. We
could not confirm the port 80 blockage since the customer is NOT the
network admin. 


Version-Release number of selected component (if applicable):
rhn_register-2.9.2-1.2.1AS

How reproducible:
Always

Steps to Reproduce:
1. "up2date --configure" and supply the correct proxyserver:port values
2. "up2date" or "rhn_register" to register the system with RHN
3.
    

Actual Results:  Error message says:

   no route to host

Expected Results:  System should be registered with RHN with no problems.

Additional info:

Possible blockage of port 80. We could not confirm this though.

The network admins must have forwarded port 443 to the proxy server
but blocked the normal http port. Users can therefore browse the
internet using the correct proxy settings or telnet outside to port 443.
Comment 1 Adrian Likins 2004-09-02 15:57:08 EDT
This should be fixed with rhel2.1-u5 (rhn_register-2.9.12,
up2date-2.9.14)

Note You need to log in before you can comment on or make changes to this bug.