Bug 116279 - (ALSA) Request for ISAPNP identifiers
(ALSA) Request for ISAPNP identifiers
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-19 12:11 EST by Michael St. Laurent
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-15 17:35:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael St. Laurent 2004-02-19 12:11:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Application is unable to detect and configure the soundcard in my 
Gateway Solo 2500 Laptop.  Since sndconfig is no longer being 
supported I no longer have any way to configure the sound card on my 
system.

Please either replace sndconfig to the distribution or add the 
ability to configure legacy sound cards to the system-config-
soundcard application.

Version-Release number of selected component (if applicable):
system-config-soundcard-1.2.2-1

How reproducible:
Always

Steps to Reproduce:
1.  Try to configure sound on a Gateway Solo 2500 laptop or other 
system with a "legacy" soundcard.
2.
3.
    

Additional info:
Comment 1 Brent Fox 2004-02-19 20:10:25 EST
sndconfig is still shipping with FC2 test 1...it's just not installed
by default.  However, I'd guess that it will not work with the 2.6
kernel so well.

Can you provide more information about the type of soundcard your
laptop has?
Comment 2 Michael St. Laurent 2004-02-19 20:29:20 EST
Hmmm, it must have been installed on my system because I chose 
the "Everything" install option.

Frankly, sndconfig was never that good with my sound card either but 
after doing a bunch of research I discovered settings that would work.

This is a several-year-old laptop and the built-in peripherals are 
not PCI or PNP or anything that nice.  It's a NeoMagic chipset sound 
card that is OPL3 compatible.  If I set the I/O Address, DMA 
channels, IRQs, etc. to match the BIOS settings then I could get it 
to work.

I can *get* more info than this if you need it but I'll have to re-
install Red Hat 9 to do so.  Let me know if it would help.
Comment 3 Michael St. Laurent 2004-02-19 20:36:16 EST
Ahhh, I got sndconfig to give me the list of cards on another system.

Oddly enough, the NeoMagic chipset listed does not work with my sound 
card.  I have to use the "OPL3-SA1" setting.  That and match the Base 
I/O Address, DMA and IRQ settings in the BIOS.
Comment 4 Brent Fox 2004-02-19 20:56:41 EST
The switch to the 2.6 kernel also means that we're switching over to
ALSA from the oss sound system.  To be honest, I don't even know if
ALSA will even work with your soundcard.  I haven't been able to get
the soundcards working on any of my FC2 test 1 installs yet.  :(

As root, run this:
kudzu --probe --class=AUDIO --bus=UNSPEC

What does the output of that say?
Comment 5 Bill Nottingham 2004-02-19 22:59:23 EST
kudzu will not probe non-isapnp/non-pci cards at all.
isapnp at the moment isn't being seen because the drivers aren't
exporting any ISAPnP ids.
Comment 6 Michael St. Laurent 2004-02-20 11:08:25 EST
<heh>  You're gonna love this... nothing.  It just gave me another 
prompt.
Comment 7 Michael St. Laurent 2004-02-20 11:14:22 EST
-> Bill Nottingham:  My above comment was directed to the kudzu 
question.

So, are the drivers being modified to export ISAPnP IDs?  Will the 
legacy cards eventually find support in the 2.6 kernel?
Comment 8 Brent Fox 2004-03-05 18:19:21 EST
Michael: That's more of a kernel question.  Perhaps you should change
the component of this bug to the kernel.
Comment 9 Michael St. Laurent 2004-03-08 12:53:41 EST
Okay, if you think that would be best.

I'm just trying to let you folks know that Sound is broken on these 
older cards.
Comment 10 Michael St. Laurent 2004-09-15 13:12:04 EDT
Request for status:  Has any progress been made towards getting the 
Kernel to export ISAPnP IDs?
Comment 11 Bill Nottingham 2004-09-15 17:35:13 EDT
Actually, this should be better in current development kudzu packages.

Note You need to log in before you can comment on or make changes to this bug.