Bug 1162793 - Lenovo Thinkpad T440s cannot resume from suspend
Summary: Lenovo Thinkpad T440s cannot resume from suspend
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-11 17:24 UTC by Valent Turkovic
Modified: 2015-01-28 14:20 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-28 13:53:31 UTC


Attachments (Terms of Use)
LXDE suspend and resume kernel messages (8.94 KB, text/plain)
2014-11-16 23:20 UTC, Valent Turkovic
no flags Details
dmesg_after (7.71 KB, text/plain)
2014-11-16 23:54 UTC, Valent Turkovic
no flags Details
suspend freeze log (7.21 KB, text/plain)
2014-11-18 18:55 UTC, Valent Turkovic
no flags Details
this is syslog of one working suspend and resume with debugging kernel (46.40 KB, patch)
2014-11-18 19:09 UTC, Valent Turkovic
no flags Details | Diff

Description Valent Turkovic 2014-11-11 17:24:11 UTC
Description of problem:
As per title, Thinkpad T440s running Fedora 21 beta (with all updates applied) will not resume from suspend, but requires a hard restart.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Suspend system via any method (close lid, press power button, press alt-power under the battery menu, run pm-suspend)

Actual results:
I can hear CPU fan starting and blowing air, but laptop still acts like it is in suspend - display is off, power button still blinks...

Expected results:
Laptop wakes up from sleep appropriately.

Additional info:
I have two boot drives, first is 500GB HDD and other is 16GB SSD. I have /boot, /boot/efi and /home partitions on regular drive and my / partition on ssh drive.

Comment 1 Peter Thorstenson 2014-11-16 10:12:34 UTC
I have the same problem as Valent described, on my Thinkpad X240 running Fedora Workstation 21 beta (Gnome), fully updated. Once suspended, the only way to get get out of the suspend state, is by holding down the power button to force a system power off and then boot it up again. The only difference is that I don't hear any noise at all from the fan when I try to resume.

When I tried Fedora 21 beta, XFCE4 spin on the same computer it did NOT present any problems at all with suspend/resume!! It worked flawlessly.

I use Legacy boot on a 1TB Samsung SSD 840 EVO (/). I also have a 16BG SSD but that is only used as a quick data backup.

Comment 2 Valent Turkovic 2014-11-16 23:20:23 UTC
(In reply to Peter Thorstenson from comment #1)
> I have the same problem as Valent described, on my Thinkpad X240 running
> Fedora Workstation 21 beta (Gnome), fully updated. Once suspended, the only
> way to get get out of the suspend state, is by holding down the power button
> to force a system power off and then boot it up again. The only difference
> is that I don't hear any noise at all from the fan when I try to resume.
> 
> When I tried Fedora 21 beta, XFCE4 spin on the same computer it did NOT
> present any problems at all with suspend/resume!! It worked flawlessly.
> 
> I use Legacy boot on a 1TB Samsung SSD 840 EVO (/). I also have a 16BG SSD
> but that is only used as a quick data backup.

After seeing Peter's message I tried suspend/resume on XFCE but I still got same result. I could hear hdd spinning up and cpu fan working, but power led would still be in suspend mode - just blinking, with screen off.

But with LXDE suspend/resume works flawlessly! In LXDE suspend works as expected with "pm-suspend" command and resume also works with power button.

Comment 3 Valent Turkovic 2014-11-16 23:20:56 UTC
Created attachment 958090 [details]
LXDE suspend and resume kernel messages

Comment 4 Valent Turkovic 2014-11-16 23:52:20 UTC
After suspend/resume worked in LXDE I tried logging out of LXDE and logging into GNOME 3, now suspend/resume also worked in GNOME 3 also!

But after reboot suspend/resume wouldn't work in any combination... I tried again logging into XFCE then into LXCE -> fail, straight to XFCE -> fail, straing into LXDE - > fail.

I tried "dmesg > dmesg_before; echo mem > /sys/power/state; dmesg > dmesg_after" as per instructions but in all cases only dmesg_before was created.

After reading https://01.org/linuxgraphics/documentation/how-debug-suspend-resume-issues-0 I had no clue what to do next...

Then I tried choosing debugging kernel in GRUB menu, and bingo! Now suspend/resume works every time in every envirnment.

Comment 5 Valent Turkovic 2014-11-16 23:54:54 UTC
Created attachment 958092 [details]
dmesg_after

Comment 6 Valent Turkovic 2014-11-17 00:30:43 UTC
On Mon, Nov 17, 2014 at 1:04 AM, Andrew Lutomirski <luto@mit.edu> wrote:
> On Sun, Nov 16, 2014 at 4:01 PM, valent.turkovic@gmail.com
> <valent.turkovic@gmail.com> wrote:
>> Just a quick update - i got suspend/resume to once randomly work in
>> LXDE environment, but after that again everytime it failed.
>>
>> Then I tried using "debugging" kernel on GRUB menu, and now each time
>> I tried suspend/resume in all environments (GNOME 3, LXDE, Cinnamon,
>> XFCE) it worked every time as expected.
>
> This smells like a no_console_suspend and/or whatever the new drm or
> i915 fast suspend/resume thing is.  Are there interesting boot
> parameters that differ between working and non-working configurations?
>
> --Andy

There is no difference in boot kernel parameters - http://fpaste.org/151332/83812141/raw/

I noticed that now that suspend/resume works it is a bit slower to suspend. On
"normal" kernel suspend is instant, when I enter "pm-suspend" or press
suspend via GUI screen just goes black right away.

With "debugging" kernel when I issue suspend command first I see lock
screen, then screen goes black, then it blinks once more with lock
screen and then it goes off.

Comment 7 Peter Thorstenson 2014-11-17 20:31:19 UTC
I ran across this: https://bbs.archlinux.org/viewtopic.php?id=187624
------------------------------------------------------
[SOLVED]Laptop doesn't resume after suspending to ram
   ...
Okay, problem is solved. Solution is disabling USB 3.0 support in BIOS. This problem is actual for all Thinkpad E[4-5]40 and T[4-5]40.
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1331077
------------------------------------------------------
I tried it, but it didn't help me. :(

Comment 8 Valent Turkovic 2014-11-17 22:15:58 UTC
(In reply to Peter Thorstenson from comment #7)
> I ran across this: https://bbs.archlinux.org/viewtopic.php?id=187624
> ------------------------------------------------------
> [SOLVED]Laptop doesn't resume after suspending to ram
>    ...
> Okay, problem is solved. Solution is disabling USB 3.0 support in BIOS. This
> problem is actual for all Thinkpad E[4-5]40 and T[4-5]40.
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1331077
> ------------------------------------------------------
> I tried it, but it didn't help me. :(

Have you tried also using "debugging" kernel? Now suspend/resume work great on my Lenovo T440s.

Comment 9 Valent Turkovic 2014-11-18 18:55:29 UTC
Created attachment 958704 [details]
suspend freeze log

These are syslog messages from successful suspend and unsucesfull resume... from the log it seams like suspend works ok, but there are no messages after that because resume fails early in the resume process so as system is not up nothing gets written into log.

I also tried pinging to see if machine is up but only that display is off, but nope, as power button is incicating by blinking - machine hasn't resumed...

Comment 10 Valent Turkovic 2014-11-18 19:09:15 UTC
Created attachment 958705 [details]
this is syslog of one working suspend and resume with debugging kernel

In this log there are clearly labeled log messaged from suspend and resume.
This suspend and resume works but only with debugging kernel, with regular kernel resume doesn't work.

Comment 11 Valent Turkovic 2014-11-18 19:52:21 UTC
Thanks to this bugreport [1] now suspend and resume work as expected on Fedora 21, finally!

Issue was with missing TPM modules! One solution would be to disable TPM in EFI/BIOS and other to install missing kernel-modules-extra package.

Now resume finally works!

Also suspend now takes almost twice long, and screen blinks quite few more times like this: on-pressed_suspend-off-on-off-on-off

But main thing is that both suspend and resume work now as expected.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1164937

Comment 12 Justin M. Forbes 2015-01-27 14:59:10 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 21 kernel bugs.

Fedora 21 has now been rebased to 3.18.3-201.fc21.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 13 Valent Turkovic 2015-01-28 08:52:31 UTC
Still works without issues with latest kernel.

Comment 14 Justin M. Forbes 2015-01-28 13:53:31 UTC
Thanks for the update!


Note You need to log in before you can comment on or make changes to this bug.