Bug 116288 - Grub Segfaults, no bootloader installed.
Summary: Grub Segfaults, no bootloader installed.
Status: CLOSED DUPLICATE of bug 112906
Alias: None
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-19 19:06 UTC by Chris Kloiber
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Kloiber 2004-02-19 19:06:10 UTC
Description of problem:

Clean ("Custom/Everything") install of FC2/x86_64 on eMachines M6807
laptop. Machine finished install, rebooted and got no grub prompt- it
went straight through to the Windows partition.

Rebooted installer in "linux rescue" chrooted into /mnt/sysimage,
verifyied correctness of /etc/grub.conf then ran:

# grub-install /dev/hda

grub had segfaulted, so no bootloader had been installed.

(Also there is no lilo to use as a workaround, but that's another bug).

Comment 1 Jeremy Katz 2004-02-19 21:09:05 UTC
What FC2 x86_64 tree?  There isn't a real one right now... and the x86
emulation was broken for a while in the kernel which is probably what
caused this.

Comment 2 Chris Kloiber 2004-02-19 22:26:23 UTC
Sorry, rawhide-20040219/x86_64 didn't realize it's not live.

Comment 3 Aleksey Nogin 2004-02-19 22:45:01 UTC

*** This bug has been marked as a duplicate of 112906 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:01:27 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.