Bug 1162914 - F21 ppc64 Beta RC1 references yaboot, but does not provide it.
Summary: F21 ppc64 Beta RC1 references yaboot, but does not provide it.
Status: CLOSED DUPLICATE of bug 1162904
Alias: None
Product: Fedora
Classification: Fedora
Component: lorax
Version: 21
Hardware: ppc64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2014-11-12 01:04 UTC by Al Dunsmuir
Modified: 2014-11-13 00:45 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-11-13 00:45:46 UTC


Attachments (Terms of Use)

Description Al Dunsmuir 2014-11-12 01:04:06 UTC
Description of problem:

In F20 and F21, anaconda was changed (based on http://www.redhat.com/archives/anaconda-devel-list/2012-March/msg00119.html) to use grub2 instead of yaboot for the stage1 boot.

Grub2 Stage 1 boot is not quite configured correctly. See https://bugzilla.redhat.com/show_bug.cgi?id=1162904 for details.

In F20, the stage2 boot continued to use ppc32 yaboot - with an issue that the yaboot.conf file forgot to specify the device stanza (and hence boot drive).

In F21, there is no more ppc32 support.  Possible solutins:
- Build yaboot under ppc64 with staticly-bound deps (glibc, nss-softokn-freebl)
  to replace the previous ppc32 shared objects
- Migrate stage 2 boot to use grub2 as well.

I would suggest doing the first given short timeframe before F21 GA, and work 
towards the latter over F22 release.

Before alpha, yaboot rpm dependency was removed BUT not the funcational dependency.

Version-Release number of selected component (if applicable):
F21 Beta RC1

How reproducible:
100%

Steps to Reproduce:
1. Install F21 on fresh G5 Mac - no stage2 boot
2. Install F21 on machine with corrected F20 yaboot setup, works.
3.

Actual results:
Intall F21 on fresh G5 Mac results in unbootable system.

Expected results:
Install F21 on fresh G5 Mac results in bootable system

Additional info:

http://www.redhat.com/archives/anaconda-devel-list/2012-March/msg00119.html

Comment 1 Al Dunsmuir 2014-11-12 01:13:40 UTC
Also see F20 BZ https://bugzilla.redhat.com/show_bug.cgi?id=1035541

RHEL 7.0 uses yaboot for boot. This boots fine on G5 Macs, at least until the kernel starts (RHEL 7 requires Power6).

RHEL 7.1 is migrating to grub2.
(see https://bugzilla.redhat.com/show_bug.cgi?id=1131199. and https://bugzilla.redhat.com/show_bug.cgi?id=1156036).

It would be helpful to have a workable solution in F21 ppc64 that also covers RHEL 7.1 release.

Comment 2 Al Dunsmuir 2014-11-12 01:31:36 UTC
Moved to lorax since bcl is doing 1131199 under that component.

Blocking the F21 ppc64 tracker bug.

Comment 3 Brian Lane 2014-11-13 00:45:46 UTC

*** This bug has been marked as a duplicate of bug 1162904 ***


Note You need to log in before you can comment on or make changes to this bug.