Bug 1163 - Update to XFree86 causes problems with netcfg
Update to XFree86 causes problems with netcfg
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-02-14 23:31 EST by kevingal
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-19 12:45:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kevingal 1999-02-14 23:31:54 EST
After upgrading to RedHat 5.2, I had no problems with
netcfg.  Then I updated to XFree86, version 3.3.3.1-1, as
recommended.  Now, when I execute netcfg for the first time
after logging in, to connect to my ISP via a PPP dialup
connection, all attempts to start X clients fail with an
error message complaining that they do not have permission
to use display ":0.0".

A rather annoying workaround is to restart X without logging
out and then re-connecting to my ISP via netcfg.
Comment 1 kevingal 1999-03-18 23:54:59 EST
I found a workaround.  I used the xhost command and added my local
host name.
Comment 2 Preston Brown 1999-03-19 12:45:59 EST
I suggest that you use xauth instead, because it is much more secure.
Do a query on www.dejanews.com on "xhost" to see horror stories.
Future releases of Red Hat Linux will not change the hostname for
dialup PPP and SLIP connections, as we have decided that this is not
safe for all programs, X being the most notable example.

Note You need to log in before you can comment on or make changes to this bug.