Bug 1163023 - certmonger 32 bits crashes after upgrading from 6.5 to 6.6
Summary: certmonger 32 bits crashes after upgrading from 6.5 to 6.6
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: certmonger
Version: 6.6
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: Jan Cholasta
QA Contact: Kaleem
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-12 09:09 UTC by Natxo Asenjo
Modified: 2015-07-22 07:17 UTC (History)
5 users (show)

(edit)
Prior to this update, after the user upgraded from Red Hat Enterprise Linux 6.5 to Red Hat Enterprise Linux 6.6 and rebooted the system, certmonger in some cases erroneously exited shortly after starting or performed a series of unnecessary checks for new certificates. A patch has been applied to fix this bug, and these problems no longer occur in the described situation.
Clone Of:
(edit)
Last Closed: 2015-07-22 07:17:32 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1379 normal SHIPPED_LIVE certmonger bug fix and enhancement update 2015-07-20 17:58:28 UTC

Description Natxo Asenjo 2014-11-12 09:09:01 UTC
Description of problem:

after upgrading from 6.5 to 6.6 the certmonger daemon crashes on 32 bit hosts

Version-Release number of selected component (if applicable):


How reproducible:

always.

Steps to Reproduce:
1. update a host running centos 6.5 to centos 6.6
2. reboot
3. certmonger stops

Actual results:
certmonger stops working

Expected results:
certmonger keeps working

Additional info:
See mailing list thread "certmonger question" on freeipa-users: https://www.redhat.com/archives/freeipa-users/2014-November/msg00156.html

Comment 2 Nalin Dahyabhai 2014-11-12 14:20:25 UTC
Where you able to check if the current snapshot package from https://jdennis.fedorapeople.org/ipa-devel/rhel/6/i386/os/ fixes the problem?

Comment 3 Natxo Asenjo 2014-11-12 15:04:31 UTC
Sorry, I just read your message. 

I have just tried it on one of the 6.6 hosts and it works!

Nice work, thanks.

Comment 6 Kaleem 2015-03-30 09:30:44 UTC
Verified.

Certmonger version:
===================
[root@dhcp207-106 ~]# rpm -q certmonger
certmonger-0.77.1-1.el6.i686
[root@dhcp207-106 ~]#

Comment 8 errata-xmlrpc 2015-07-22 07:17:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1379.html


Note You need to log in before you can comment on or make changes to this bug.