Bug 1163042 - Bundler can't see its dependencies after Bundler.setup [fedora-20]
Summary: Bundler can't see its dependencies after Bundler.setup [fedora-20]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rubygem-bundler
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vít Ondruch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1163039
Blocks: 1163041
TreeView+ depends on / blocked
 
Reported: 2014-11-12 09:41 UTC by Josef Stribny
Modified: 2016-01-04 05:53 UTC (History)
7 users (show)

Fixed In Version: rubygem-bundler-1.7.6-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of: 1163039
Environment:
Last Closed: 2014-11-25 15:30:45 UTC


Attachments (Terms of Use)

Description Josef Stribny 2014-11-12 09:41:50 UTC
+++ This bug was initially created as a clone of Bug #1163039 +++

Description of problem:

Bundler can't see its dependencies after Bundler.setup.

If thor or net-http-persistent are already in memory, Bundler can reuse them just fine, but if Bundler locks the Gemfile and those libs are not already loaded, Bundler doesn't see them even though they are its dependencies. 

Originally these dependencies are vendored inside the gem, but we removed them in Fedora. For Bundler to function as expected and designed by upstream we should most likely symlink the originally vendored libs to system-installed RubyGems.

I am including a simple reproducer for rawhide although I came across this in the real usecase when Vagrant couldn't download remote plugins, because Bundler (which Vagrant uses underneath) uses net-http-persistent for that.


How reproducible:

$ bundle init
$ irb
> require 'bundler'
> Bundler.setup
> require 'bundler/vendored_thor'
LoadError: cannot load such file -- thor
	from /usr/share/gems/gems/bundler-1.7.4/lib/bundler/vendored_thor.rb:7:in `require'
	from /usr/share/gems/gems/bundler-1.7.4/lib/bundler/vendored_thor.rb:7:in `<top (required)>'
	from (irb):5:in `require'
	from (irb):5
	from /usr/bin/irb:11:in `<main>'

Comment 1 Fedora Update System 2014-11-12 13:55:08 UTC
rubygem-bundler-1.7.6-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/rubygem-bundler-1.7.6-1.fc20

Comment 2 Fedora Update System 2014-11-13 18:08:05 UTC
Package rubygem-bundler-1.7.6-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rubygem-bundler-1.7.6-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-14831/rubygem-bundler-1.7.6-1.fc20
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2014-11-25 15:30:45 UTC
rubygem-bundler-1.7.6-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.