Bug 1163106 - [abrt] libreoffice-core: soffice.bin killed by SIGABRT on shutdown in tdoc_ucp::OfficeDocumentsManager::OfficeDocumentsCloseListener
Summary: [abrt] libreoffice-core: soffice.bin killed by SIGABRT on shutdown in tdoc_uc...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Stahl
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:c802ab4613fb64bbe7d25a538d8...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-12 12:06 UTC by György Nagy
Modified: 2015-01-19 12:14 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-19 12:14:50 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (46.80 KB, text/plain)
2014-11-12 12:06 UTC, György Nagy
no flags Details
File: cgroup (180 bytes, text/plain)
2014-11-12 12:06 UTC, György Nagy
no flags Details
File: core_backtrace (28.27 KB, text/plain)
2014-11-12 12:06 UTC, György Nagy
no flags Details
File: dso_list (27.69 KB, text/plain)
2014-11-12 12:06 UTC, György Nagy
no flags Details
File: environ (1.82 KB, text/plain)
2014-11-12 12:06 UTC, György Nagy
no flags Details
File: limits (1.29 KB, text/plain)
2014-11-12 12:06 UTC, György Nagy
no flags Details
File: maps (131.10 KB, text/plain)
2014-11-12 12:06 UTC, György Nagy
no flags Details
File: open_fds (546 bytes, text/plain)
2014-11-12 12:07 UTC, György Nagy
no flags Details
File: proc_pid_status (951 bytes, text/plain)
2014-11-12 12:07 UTC, György Nagy
no flags Details
File: var_log_messages (228 bytes, text/plain)
2014-11-12 12:07 UTC, György Nagy
no flags Details

Description György Nagy 2014-11-12 12:06:46 UTC
Version-Release number of selected component:
libreoffice-core-4.2.7.2-2.fc20

Additional info:
reporter:       libreport-2.2.3
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer --splash-pipe=5
crash_function: __gnu_cxx::__verbose_terminate_handler()
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.16.6-203.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 __gnu_cxx::__verbose_terminate_handler() at /lib64/libstdc++.so.6
 #3 ?? at /lib64/libstdc++.so.6
 #4 std::terminate() at /lib64/libstdc++.so.6
 #5 __cxa_pure_virtual at /lib64/libstdc++.so.6
 #6 tdoc_ucp::OfficeDocumentsManager::OfficeDocumentsCloseListener::notifyClosing(com::sun::star::lang::EventObject const&) at /usr/lib64/libreoffice/program/../program/libucptdoc1lo.so
 #7 SfxBaseModel::close(unsigned char) at /usr/lib64/libreoffice/program/libsfxlo.so
 #8 SfxBaseModel::dispose() at /usr/lib64/libreoffice/program/libsfxlo.so
 #9 void comphelper::disposeComponent<com::sun::star::sheet::XSpreadsheetDocument>(com::sun::star::uno::Reference<com::sun::star::sheet::XSpreadsheetDocument>&) at /usr/lib64/libreoffice/program/../program/libcalclo.so
 #10 connectivity::calc::OCalcConnection::disposing() at /usr/lib64/libreoffice/program/../program/libcalclo.so
 #11 cppu::WeakComponentImplHelperBase::dispose() at /usr/lib64/libreoffice/program/../ure-link/lib/libuno_cppuhelpergcc3.so.3

Comment 1 György Nagy 2014-11-12 12:06:50 UTC
Created attachment 956701 [details]
File: backtrace

Comment 2 György Nagy 2014-11-12 12:06:51 UTC
Created attachment 956702 [details]
File: cgroup

Comment 3 György Nagy 2014-11-12 12:06:53 UTC
Created attachment 956703 [details]
File: core_backtrace

Comment 4 György Nagy 2014-11-12 12:06:54 UTC
Created attachment 956704 [details]
File: dso_list

Comment 5 György Nagy 2014-11-12 12:06:55 UTC
Created attachment 956705 [details]
File: environ

Comment 6 György Nagy 2014-11-12 12:06:56 UTC
Created attachment 956706 [details]
File: limits

Comment 7 György Nagy 2014-11-12 12:06:58 UTC
Created attachment 956707 [details]
File: maps

Comment 8 György Nagy 2014-11-12 12:07:00 UTC
Created attachment 956708 [details]
File: open_fds

Comment 9 György Nagy 2014-11-12 12:07:01 UTC
Created attachment 956709 [details]
File: proc_pid_status

Comment 10 György Nagy 2014-11-12 12:07:02 UTC
Created attachment 956710 [details]
File: var_log_messages

Comment 11 Caolan McNamara 2014-11-12 13:46:46 UTC
Is this reproducible, or a one time thing ?

Comment 12 György Nagy 2014-11-24 17:28:27 UTC
Dear (In reply to Caolan McNamara from comment #11)
> Is this reproducible, or a one time thing ?

I can not reproduce the failure. It happened during them "Mail Merge Wizard".

Comment 13 Alex 2014-12-18 02:52:24 UTC
Another user experienced a similar problem:

while working on Wordpress blog, I was switching among several windows in Firefox and Konqueror.
Concerning specifically Libre Office, I was inserting footonotes and decided to change their format when the program failed.

reporter:       libreport-2.2.3
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer --splash-pipe=5
crash_function: __gnu_cxx::__verbose_terminate_handler()
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.17.6-200.fc20.x86_64
package:        libreoffice-core-4.2.7.2-11.fc20
reason:         soffice.bin killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 14 Michael Stahl 2015-01-15 21:03:24 UTC
this is quite similar to bug 1175027, just with a different listener.

pretty sure there's a memory leak involving a database document or connection at the root of this...

crash should be fixed on upstream master by commit 0ffa3abc7d6c0437ece30cfb1430d28ffcc9f5c1

Comment 15 Michael Stahl 2015-01-19 12:14:50 UTC
fixed on upstream libreoffice-4-4 branch for 4.4.1 release: commit 
8f00af819f024212c9362aa3c98000f5dff549d3

fixed on upstream libreoffice-4-3 branch for 4.3.7 release: commit 
4df44ecc61e2baf168bb425c96bf70fd7deb5b64

since this crash happens only on exit, it's not that important anyway so i'll not add the patch to Fedora packages, they can wait for the upstream release.


Note You need to log in before you can comment on or make changes to this bug.