Bug 1163107 - [RFE] Use cloud-init instead of the firstboot menu
Summary: [RFE] Use cloud-init instead of the firstboot menu
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-appliance
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-3.6.0-rc3
: 3.6.0
Assignee: Anatoly Litovsky
QA Contact: Gonza
URL:
Whiteboard:
Depends On: 1198138
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-12 12:08 UTC by Moran Goldboim
Modified: 2016-03-09 21:43 UTC (History)
9 users (show)

Fixed In Version: rhevm-appliance-20151029.2-1
Doc Type: Enhancement
Doc Text:
With this enhancement, the RHEV-M appliance now uses cloud-init for initial virtual machine configuration instead of the first-boot dialog.
Clone Of:
Environment:
Last Closed: 2016-03-09 21:43:41 UTC
oVirt Team: Node
Target Upstream Version:
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1198138 high CLOSED [RFE] Add the capability to attach an ISO image for cloud-init configuration 2020-10-14 00:28:05 UTC
Red Hat Product Errata RHBA-2016:0385 normal SHIPPED_LIVE rhevm-appliance bug fix and enhancement update 2016-03-10 02:43:23 UTC

Description Moran Goldboim 2014-11-12 12:08:16 UTC
Description of problem:
firstboot menu is problematic when we want to automate deployment and configure rhevm appliance. since the vm doesn't boot unless been configured from first boot menu.
specially with the combination of hosted engine, everything can be configured using cloud-init, and appliance can be run with hostname/network and root password configured already


Version-Release number of selected component (if applicable):
3.5.0

How reproducible:
always

Steps to Reproduce:
1.boot the appliance
2.
3.

Actual results:


Expected results:


Additional info:
needed for RHCI common installer.

Comment 1 Fabian Deutsch 2014-11-12 14:49:19 UTC
I understand the problem, and we want to address it, but let's do this after 3.5.0, and maybe consider it for a z-stream.

The reason is that it requires
1. rel-eng changes
2. Testing
3. development

Comment 2 Doron Fediuck 2014-11-13 07:13:49 UTC
Fixing target version to consider it for 3.5.z.

Comment 3 Fabian Deutsch 2014-11-18 12:03:23 UTC
As discussed on the email thread, I'd rather like to enable cloud-init in the image and use the cloud-init fallback method with an attached media.

The root password and network configuration can then be set using cloud-init's fallback method:
http://cloudinit.readthedocs.org/en/latest/topics/datasources.html#fallback-none

That way the cloud-init code path is tested twice: during automation and when the regular testing is taking place.

Comment 4 Fabian Deutsch 2015-02-12 11:49:23 UTC
For several reasons it makes sense to be able to configure the image using cloud-init, some of them in no particular order:
- cloud-init is used in OpenStack and RHEV
- The initial setup dialog prevents easy automation
- cloud-init can be used to inject an ssh key etc

In summary we want to use cloud-init as a defacto standard for the bootstrap configuration of this image.

This RFE needs to cover several aspects:
1. Enable cloud-init in the image
2. Disable the initial setup dialog
3. Test
3.a That cloud-init works when the image is used in RHEV
3.b That cloud-init works when the image is used in OpenStack
3.c That cloud-init works locally when using teh fallback method as described here: https://www.technovelty.org//linux/running-cloud-images-locally.html
4. Add and reference documentation if it exists elsewhere
5. Ensure that the build process works, including the errata process

Comment 12 Fabian Deutsch 2015-09-22 10:40:57 UTC
This feature is actually now differnt. cloud-init is not an alternative, but cloud-init is now the only option to configure the appliance on the first boot.

This is already handled by hosted-engine-setup.

Comment 15 Gonza 2015-11-26 15:56:05 UTC
Point 3a from #c4 has been verified with:
rhevm-appliance-20151119.0-1

rhevm-appliance cloud-init is working for rhevm.

Could we assign this to someone from Openstack QE or create separate BZ for it?

Comment 16 Fabian Deutsch 2015-11-26 16:00:09 UTC
Thanks.

No, OpenSTACK QE does not need to test this image right now.
This image is tuned towards the Hosted-Engine flow.

Advertising it in OpenStack right now will probably raise false expectations.

Comment 18 errata-xmlrpc 2016-03-09 21:43:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0385


Note You need to log in before you can comment on or make changes to this bug.