Bug 116316 - make modules failing to create /lib/modules/`uname -r`
make modules failing to create /lib/modules/`uname -r`
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ernie Petrides
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-19 18:47 EST by Jon Sabo
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-15 19:46:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Sabo 2004-02-19 18:47:21 EST
Description of problem:

Building kernel on up2date as of Thurs. Feb. 19th 2004 rhel-ws 3.0
fails during make modules install.

Version-Release number of selected component (if applicable):


How reproducible:

Build kernel and try to do make modules install 
Steps to Reproduce:
1. make mrproper
2. make oldconfig ( after moving over a .config )
3. make dep
4. make bzImage
5. make modules
6. make modules install
  
Actual results:

Fails to create /lib/modules/`uname-r` and move the files into the
directory.

Expected results:

Make modules to work like it ususally does.  Honestly I dont know why
its not working, I could be doing something wrong but I have been
doing this for years and I have never had this not work.  I  have been
trying to compile a kernel on this system for hours now. 


Additional info:
Comment 1 Jon Sabo 2004-02-19 18:50:07 EST
make CFLAGS="-D__KERNEL__ -I/usr/src/linux-2.4.25/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing
-fno-common -fomit-frame-pointer -pipe -mpreferred-stack-boundary=2
-march=i686 " -C  arch/i386/mm
make[1]: Entering directory `/usr/src/linux-2.4.25/arch/i386/mm'
make all_targets
make[2]: Entering directory `/usr/src/linux-2.4.25/arch/i386/mm'
make[2]: Nothing to be done for `all_targets'.
make[2]: Leaving directory `/usr/src/linux-2.4.25/arch/i386/mm'
make[1]: Leaving directory `/usr/src/linux-2.4.25/arch/i386/mm'
make CFLAGS="-D__KERNEL__ -I/usr/src/linux-2.4.25/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing
-fno-common -fomit-frame-pointer -pipe -mpreferred-stack-boundary=2
-march=i686 " -C  arch/i386/lib
make[1]: Entering directory `/usr/src/linux-2.4.25/arch/i386/lib'
make all_targets
make[2]: Entering directory `/usr/src/linux-2.4.25/arch/i386/lib'
make[2]: Nothing to be done for `all_targets'.
make[2]: Leaving directory `/usr/src/linux-2.4.25/arch/i386/lib'
make[1]: Leaving directory `/usr/src/linux-2.4.25/arch/i386/lib'
ld -m elf_i386 -T /usr/src/linux-2.4.25/arch/i386/vmlinux.lds -e stext
arch/i386/kernel/head.o arch/i386/kernel/init_task.o init/main.o
init/version.o init/do_mounts.o \
        --start-group \
        arch/i386/kernel/kernel.o arch/i386/mm/mm.o kernel/kernel.o
mm/mm.o fs/fs.o ipc/ipc.o \
         drivers/acpi/acpi.o drivers/char/char.o drivers/block/block.o
drivers/misc/misc.o drivers/net/net.o drivers/char/drm/drm.o
drivers/net/fc/fc.o drivers/net/appletalk/appletalk.o
drivers/net/tokenring/tr.o drivers/net/wan/wan.o drivers/atm/atm.o
drivers/ide/idedriver.o drivers/cdrom/driver.o drivers/pci/driver.o
drivers/net/pcmcia/pcmcia_net.o drivers/net/wireless/wireless_net.o
drivers/pnp/pnp.o drivers/video/video.o
drivers/net/hamradio/hamradio.o drivers/media/media.o
drivers/md/mddev.o drivers/hotplug/vmlinux-obj.o
drivers/isdn/vmlinux-obj.o crypto/crypto.o \
        net/network.o \
        /usr/src/linux-2.4.25/arch/i386/lib/lib.a
/usr/src/linux-2.4.25/lib/lib.a
/usr/src/linux-2.4.25/arch/i386/lib/lib.a \
        --end-group \
        -o vmlinux
nm vmlinux | grep -v '\(compiled\)\|\(\.o$\)\|\( [aUw]
\)\|\(\.\.ng$\)\|\(LASH[RL]DI\)' | sort > System.map
make[1]: Entering directory `/usr/src/linux-2.4.25/arch/i386/boot'
gcc -E -D__KERNEL__ -I/usr/src/linux-2.4.25/include -D__BIG_KERNEL__
-D__ASSEMBLY__ -traditional -DSVGA_MODE=NORMAL_VGA  setup.S -o bsetup.s
as -o bsetup.o bsetup.s
setup.S: Assembler messages:
setup.S:313: Warning: indirect lcall without `*'
ld -m elf_i386 -Ttext 0x0 -s --oformat binary -e begtext -o bsetup
bsetup.o
make[2]: Entering directory
`/usr/src/linux-2.4.25/arch/i386/boot/compressed'
tmppiggy=_tmp_$$piggy; \
rm -f $tmppiggy $tmppiggy.gz $tmppiggy.lnk; \
objcopy -O binary -R .note -R .comment -S
/usr/src/linux-2.4.25/vmlinux $tmppiggy; \
gzip -f -9 < $tmppiggy > $tmppiggy.gz; \
echo "SECTIONS { .data : { input_len = .; LONG(input_data_end -
input_data) input_data = .; *(.data) input_data_end = .; }}" >
$tmppiggy.lnk; \ld -m elf_i386 -r -o piggy.o -b binary $tmppiggy.gz -b
elf32-i386 -T $tmppiggy.lnk; \
rm -f $tmppiggy $tmppiggy.gz $tmppiggy.lnk
ld -m elf_i386 -Ttext 0x100000 -e startup_32 -o bvmlinux head.o misc.o
piggy.o
make[2]: Leaving directory
`/usr/src/linux-2.4.25/arch/i386/boot/compressed'
objcopy -O binary -R .note -R .comment -S compressed/bvmlinux
compressed/bvmlinux.out
tools/build -b bbootsect bsetup compressed/bvmlinux.out CURRENT > bzImage
Root device is (8, 5)
Boot sector 512 bytes.
Setup is 4885 bytes.
System is 990 kB
warning: kernel is too big for standalone boot from floppy
sh -x ./install.sh 2.4.25 bzImage /usr/src/linux-2.4.25/System.map ""
+ '[' -x /root/bin/installkernel ']'
+ '[' -x /sbin/installkernel ']'
+ exec /sbin/installkernel 2.4.25 bzImage
/usr/src/linux-2.4.25/System.map ''
depmod: Can't open /lib/modules/2.4.25/modules.dep for writing
/lib/modules/2.4.25 is not a directory.
mkinitrd failed
make[1]: *** [install] Error 1
make[1]: Leaving directory `/usr/src/linux-2.4.25/arch/i386/boot'
make: *** [install] Error 2
[root@everest linux-2.4.25]# 

[root@everest boot]# pwd
/usr/src/linux-2.4.25/arch/i386/boot
[root@everest boot]# ls
bbootsect    bbootsect.s  bsetup    bsetup.s  compressed  Makefile  tools
bbootsect.o  bootsect.S   bsetup.o  bzImage   install.sh  setup.S  
video.S

[root@everest fs]# pwd
/usr/src/linux-2.4.25/fs
[root@everest fs]# ls
adfs           binfmt_elf.c     ChangeLog   dnotify.c  fifo.c        
hpfs        jfs           ncpfs       qnx4          reiserfs    udf
affs           binfmt_elf.o     char_dev.c  dnotify.o  fifo.o        
inode.c     lockd         nfs         quota.c       romfs       ufs
attr.c         binfmt_em86.c    char_dev.o  dquot.c    file.c        
inode.o     locks.c       nfsd        quota.o       select.c    umsdos
attr.o         binfmt_misc.c    coda        dquot.o    file.o        
intermezzo  locks.o       nls         quota_v1.c    select.o    vfat
autofs         binfmt_misc.o    Config.in   efs        filesystems.c 
iobuf.c     Makefile      ntfs        quota_v1.o    seq_file.c  xattr.c
autofs4        binfmt_script.c  cramfs      exec.c     filesystems.o 
iobuf.o     Makefile.lib  open.c      quota_v2.c    seq_file.o  xattr.o
bad_inode.c    binfmt_script.o  dcache.c    exec.o     file_table.c  
ioctl.c     minix         open.o      quota_v2.o    smbfs       xfs
bad_inode.o    binfmt_som.c     dcache.o    ext2       file_table.o  
ioctl.o     msdos         openpromfs  ramfs         stat.c
befs           block_dev.c      devfs       ext3       freevxfs      
isofs       namei.c       partitions  readdir.c     stat.o
bfs            block_dev.o      devices.c   fat        fs.o          
jbd         namei.o       pipe.c      readdir.o     super.c
binfmt_aout.c  buffer.c         devices.o   fcntl.c    hfs           
jffs        namespace.c   pipe.o      read_write.c  super.o
binfmt_aout.o  buffer.o         devpts      fcntl.o    hfsplus       
jffs2       namespace.o   proc        read_write.o  sysv
[root@everest fs]#
Comment 3 Ernie Petrides 2004-03-05 19:13:58 EST
Hello, Jon.  Red Hat Enterprise Linux version 3 is not based on
linux-2.4.25.  What software are you reporting a bug on?
Comment 4 Ernie Petrides 2005-02-15 19:46:31 EST
Closing due to lack of response.

Note You need to log in before you can comment on or make changes to this bug.