Bug 116322 - RFE: notify user of dhcp client failures
Summary: RFE: notify user of dhcp client failures
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-20 01:43 UTC by Mike MacCana
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-22 14:36:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike MacCana 2004-02-20 01:43:24 UTC
Description of problem:  
If DHCP is being used to get an address, and the DHCP client times 
out, the user is currently dumped back to the IP address 
configuration dialog. I train RHCEs for Red Hat, and notice that 
when users are kickstarting systems and DHCP fails, they're often a 
little confused about what's happened - thinking that if the system 
is prompting them for an IP, their kickstart file must have failed. 
 
Of course, the user could look in the VTs to see the DHCP client 
time out, but since most other error messages appear in the 
installer, even somewhat experienced users don't typically think to 
do this. 
 
How reproducible:  
Always  
  
Steps to Reproduce:  
1.Use DHCP to perform a network install 
2.Have the DHCP client fail. 
    
Actual results:  
The user is given no notification that DHCp has failed, and are sent 
back to the IP configuration screen. 
  
Expected results:  
The user should be notified of the error before asking them to 
reconfigure and retry their networking. For example: 
'The system was unable to get an IP address from the DHCP server. 
Please check your network cabling, or set an IP address manually' or 
a better error message.

Comment 1 Suzanne Hillman 2004-02-20 19:09:42 UTC
Internal RFE bug #116400 entered; will be considered for future releases.

Comment 2 Suzanne Hillman 2004-04-22 14:36:54 UTC
Thank you for the suggestion. It was passed along to product
management, but not committed for a future release.


Note You need to log in before you can comment on or make changes to this bug.