Bug 116324 - cupsd exits with signal 11.
cupsd exits with signal 11.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-19 20:47 EST by Mark Lane
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.20-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-25 18:41:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of strace -f cupsd (22.85 KB, text/plain)
2004-02-20 14:41 EST, Mark Lane
no flags Details
strace -f /usr/bin/dbus-daemon-1 >& dbus.trace (3.05 KB, text/plain)
2004-02-24 12:29 EST, Mark Lane
no flags Details

  None (edit)
Description Mark Lane 2004-02-19 20:47:29 EST
Description of problem: 
after upgrade to cups-1.1.20-4, cupsd won't start giving a signal 11.

Version-Release number of selected component (if applicable): 1.1.20-4


How reproducible:
Every time I try to restart cupsd. I down graded back to cups-1.1.19-3
but to no avail.


Additional info:
Here's a strace of cupsd after going back to 1.1.19-3

strace cupsd
execve("/usr/sbin/cupsd", ["cupsd"], [/* 26 vars */]) = 0
uname({sys="Linux", node="skip.harddata.net", ...}) = 0
brk(0)                                  = 0x539000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0x2a9556a000
open("/etc/ld.so.preload", O_RDONLY)    = -1 ENOENT (No such file or
directory)
open("/usr/lib64/tls/x86_64/libz.so.1", O_RDONLY) = -1 ENOENT (No such
file or directory)
stat("/usr/lib64/tls/x86_64", 0xbfffef80) = -1 ENOENT (No such file or
directory)
open("/usr/lib64/tls/libz.so.1", O_RDONLY) = -1 ENOENT (No such file
or directory)
stat("/usr/lib64/tls", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
open("/usr/lib64/x86_64/libz.so.1", O_RDONLY) = -1 ENOENT (No such
file or directory)
stat("/usr/lib64/x86_64", 0xbfffef80)   = -1 ENOENT (No such file or
directory)
open("/usr/lib64/libz.so.1", O_RDONLY)  = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\0\37\0\0"...,
640) = 640
fstat(3, {st_mode=S_IFREG|0755, st_size=76976, ...}) = 0
mmap(NULL, 1123656, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x2a95658000
mprotect(0x2a9566b000, 1045832, PROT_NONE) = 0
mmap(0x2a95758000, 77824, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED,
3, 0) = 0x2a95758000
close(3)                                = 0
open("/usr/lib64/tls/libssl.so.4", O_RDONLY) = -1 ENOENT (No such file
or directory)
open("/usr/lib64/libssl.so.4", O_RDONLY) = -1 ENOENT (No such file or
directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=123457, ...}) = 0
mmap(NULL, 123457, PROT_READ, MAP_PRIVATE, 3, 0) = 0x2a9576b000
close(3)                                = 0
open("/lib64/libssl.so.4", O_RDONLY)    = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\200\345"...,
640) = 640
fstat(3, {st_mode=S_IFREG|0755, st_size=241600, ...}) = 0
mmap(NULL, 1291840, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x2a9578a000
mprotect(0x2a957c0000, 1070656, PROT_NONE) = 0
mmap(0x2a9588a000, 241664, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED, 3, 0) = 0x2a9588a000
mmap(0x2a958c5000, 1600, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x2a958c5000
close(3)                                = 0
open("/usr/lib64/tls/libcrypto.so.4", O_RDONLY) = -1 ENOENT (No such
file or directory)
open("/usr/lib64/libcrypto.so.4", O_RDONLY) = -1 ENOENT (No such file
or directory)
open("/lib64/libcrypto.so.4", O_RDONLY) = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\0\305\4"...,
640) = 640
fstat(3, {st_mode=S_IFREG|0755, st_size=1231488, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0x2a958c6000
mmap(NULL, 2295800, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x2a958c7000
mprotect(0x2a959d7000, 1181688, PROT_NONE) = 0
mmap(0x2a95ac7000, 184320, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED, 3, 0x100000) = 0x2a95ac7000
mmap(0x2a95af4000, 14328, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x2a95af4000
close(3)                                = 0
open("/usr/lib64/tls/libpam.so.0", O_RDONLY) = -1 ENOENT (No such file
or directory)
open("/usr/lib64/libpam.so.0", O_RDONLY) = -1 ENOENT (No such file or
directory)
open("/lib64/libpam.so.0", O_RDONLY)    = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\0\35\0\0"...,
640) = 640
fstat(3, {st_mode=S_IFREG|0755, st_size=32816, ...}) = 0
mmap(NULL, 1079488, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x2a95af8000
mprotect(0x2a95b00000, 1046720, PROT_NONE) = 0
mmap(0x2a95bf8000, 32768, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED,
3, 0) = 0x2a95bf8000
close(3)                                = 0
open("/usr/lib64/tls/libdl.so.2", O_RDONLY) = -1 ENOENT (No such file
or directory)
open("/usr/lib64/libdl.so.2", O_RDONLY) = -1 ENOENT (No such file or
directory)
open("/lib64/libdl.so.2", O_RDONLY)     = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0 \33\0\0"...,
640) = 640
fstat(3, {st_mode=S_IFREG|0755, st_size=1061424, ...}) = 0
mmap(NULL, 1052936, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x2a95c00000
mprotect(0x2a95c03000, 1040648, PROT_NONE) = 0
mmap(0x2a95d00000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED,
3, 0x100000) = 0x2a95d00000
close(3)                                = 0
open("/usr/lib64/tls/libcups.so.2", O_RDONLY) = -1 ENOENT (No such
file or directory)
open("/usr/lib64/libcups.so.2", O_RDONLY) = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\300o\0\0"...,
640) = 640
fstat(3, {st_mode=S_IFREG|0755, st_size=120024, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0x2a95d02000
mmap(NULL, 1168864, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x2a95d03000
mprotect(0x2a95d1f000, 1054176, PROT_NONE) = 0
mmap(0x2a95e03000, 118784, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED, 3, 0) = 0x2a95e03000
mmap(0x2a95e20000, 1504, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x2a95e20000
close(3)                                = 0
open("/usr/lib64/tls/libnsl.so.1", O_RDONLY) = -1 ENOENT (No such file
or directory)
open("/usr/lib64/libnsl.so.1", O_RDONLY) = -1 ENOENT (No such file or
directory)
open("/lib64/libnsl.so.1", O_RDONLY)    = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\0Q\0\0\0"...,
640) = 640
fstat(3, {st_mode=S_IFREG|0755, st_size=1076280, ...}) = 0
mmap(NULL, 1064168, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x2a95e21000
mprotect(0x2a95e34000, 986344, PROT_NONE) = 0
mmap(0x2a95f21000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED,
3, 0x100000) = 0x2a95f21000
mmap(0x2a95f23000, 7400, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x2a95f23000
close(3)                                = 0
open("/usr/lib64/tls/libcrypt.so.1", O_RDONLY) = -1 ENOENT (No such
file or directory)
open("/usr/lib64/libcrypt.so.1", O_RDONLY) = -1 ENOENT (No such file
or directory)
open("/lib64/libcrypt.so.1", O_RDONLY)  = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0@\v\0\0\0"...,
640) = 640
fstat(3, {st_mode=S_IFREG|0755, st_size=1061008, ...}) = 0
mmap(NULL, 1241504, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x2a95f25000
mprotect(0x2a95f2a000, 1221024, PROT_NONE) = 0
mmap(0x2a96025000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED,
3, 0x100000) = 0x2a96025000
mmap(0x2a96027000, 184736, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x2a96027000
close(3)                                = 0
open("/usr/lib64/tls/libdbus-1.so.0", O_RDONLY) = -1 ENOENT (No such
file or directory)
open("/usr/lib64/libdbus-1.so.0", O_RDONLY) = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0@i\0\0\0"...,
640) = 640
fstat(3, {st_mode=S_IFREG|0755, st_size=209656, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0x2a96055000
mmap(NULL, 1256864, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x2a96056000
mprotect(0x2a96088000, 1052064, PROT_NONE) = 0
mmap(0x2a96156000, 208896, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED, 3, 0) = 0x2a96156000
close(3)                                = 0
open("/usr/lib64/tls/libc.so.6", O_RDONLY) = -1 ENOENT (No such file
or directory)
open("/usr/lib64/libc.so.6", O_RDONLY)  = -1 ENOENT (No such file or
directory)
open("/lib64/tls/libc.so.6", O_RDONLY)  = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0P\315\1\0"...,
640) = 640
lseek(3, 624, SEEK_SET)                 = 624
read(3, "\4\0\0\0\20\0\0\0\1\0\0\0GNU\0\0\0\0\0\2\0\0\0\4\0\0\0"...,
32) = 32
fstat(3, {st_mode=S_IFREG|0755, st_size=2479360, ...}) = 0
mmap(NULL, 2137864, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x2a96189000
mprotect(0x2a962c5000, 843528, PROT_NONE) = 0
mmap(0x2a96389000, 24576, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED,
3, 0x200000) = 0x2a96389000
mmap(0x2a9638f000, 16136, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x2a9638f000
close(3)                                = 0
open("/usr/lib64/tls/libgssapi_krb5.so.2", O_RDONLY) = -1 ENOENT (No
such file or directory)
open("/usr/lib64/libgssapi_krb5.so.2", O_RDONLY) = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0@i\0\0\0"...,
640) = 640
fstat(3, {st_mode=S_IFREG|0755, st_size=87416, ...}) = 0
mmap(NULL, 1134192, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x2a96393000
mprotect(0x2a963a7000, 1052272, PROT_NONE) = 0
mmap(0x2a96493000, 86016, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED,
3, 0) = 0x2a96493000
close(3)                                = 0
open("/usr/lib64/tls/libkrb5.so.3", O_RDONLY) = -1 ENOENT (No such
file or directory)
open("/usr/lib64/libkrb5.so.3", O_RDONLY) = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0@l\1\0\0"...,
640) = 640
fstat(3, {st_mode=S_IFREG|0755, st_size=454224, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0x2a964a8000
mmap(NULL, 1501568, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x2a964a9000
mprotect(0x2a96515000, 1059200, PROT_NONE) = 0
mmap(0x2a965a9000, 454656, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED, 3, 0) = 0x2a965a9000
close(3)                                = 0
open("/usr/lib64/tls/libcom_err.so.2", O_RDONLY) = -1 ENOENT (No such
file or directory)
open("/usr/lib64/libcom_err.so.2", O_RDONLY) = -1 ENOENT (No such file
or directory)
open("/usr/lib64/tls/libcom_err.so.2", O_RDONLY) = -1 ENOENT (No such
file or directory)
open("/usr/lib64/libcom_err.so.2", O_RDONLY) = -1 ENOENT (No such file
or directory)
open("/lib64/libcom_err.so.2", O_RDONLY) = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\200\f\0"...,
640) = 640
fstat(3, {st_mode=S_IFREG|0755, st_size=8056, ...}) = 0
mmap(NULL, 1054872, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x2a96618000
mprotect(0x2a9661a000, 1046680, PROT_NONE) = 0
mmap(0x2a96718000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED,
3, 0) = 0x2a96718000
close(3)                                = 0
open("/usr/lib64/tls/libk5crypto.so.3", O_RDONLY) = -1 ENOENT (No such
file or directory)
open("/usr/lib64/libk5crypto.so.3", O_RDONLY) = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\0Q\0\0\0"...,
640) = 640
fstat(3, {st_mode=S_IFREG|0755, st_size=145624, ...}) = 0
mmap(NULL, 1193832, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x2a9671a000
mprotect(0x2a9673c000, 1054568, PROT_NONE) = 0
mmap(0x2a9681a000, 147456, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED, 3, 0) = 0x2a9681a000
close(3)                                = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0x2a9683e000
open("/usr/lib64/tls/libresolv.so.2", O_RDONLY) = -1 ENOENT (No such
file or directory)
open("/usr/lib64/libresolv.so.2", O_RDONLY) = -1 ENOENT (No such file
or directory)
open("/usr/lib64/tls/libresolv.so.2", O_RDONLY) = -1 ENOENT (No such
file or directory)
open("/usr/lib64/libresolv.so.2", O_RDONLY) = -1 ENOENT (No such file
or directory)
open("/lib64/libresolv.so.2", O_RDONLY) = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\0=\0\0\0"...,
640) = 640
fstat(3, {st_mode=S_IFREG|0755, st_size=1069000, ...}) = 0
mmap(NULL, 1064072, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x2a9683f000
mprotect(0x2a9684f000, 998536, PROT_NONE) = 0
mmap(0x2a9693f000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED,
3, 0x100000) = 0x2a9693f000
mmap(0x2a96941000, 7304, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x2a96941000
close(3)                                = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0x2a96943000
mprotect(0x2a9693f000, 4096, PROT_READ) = 0
mprotect(0x2a96389000, 16384, PROT_READ) = 0
mprotect(0x2a96025000, 4096, PROT_READ) = 0
mprotect(0x2a95f21000, 4096, PROT_READ) = 0
mprotect(0x2a95d00000, 4096, PROT_READ) = 0
mprotect(0x2a95656000, 4096, PROT_READ) = 0
arch_prctl(0x1002, 0x2a969434c0)        = 0
munmap(0x2a9576b000, 123457)            = 0
brk(0)                                  = 0x539000
brk(0x55a000)                           = 0x55a000
brk(0)                                  = 0x55a000
rt_sigaction(SIGUSR1, {0x414600, [USR1], 0x4000000}, NULL, 8) = 0
rt_sigaction(SIGCHLD, {0x414600, [USR1], 0x4000000}, NULL, 8) = 0
rt_sigaction(SIGHUP, {SIG_IGN}, NULL, 8) = 0
clone(child_stack=0,
flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD,
child_tidptr=0x2a96943550) = 11962
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigaction(SIGCHLD, NULL, {0x414600, [USR1], 0x4000000}, 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
nanosleep({1, 0}, 0xbfffb390)           = ? ERESTART_RESTARTBLOCK (To
be restarted)
--- SIGCHLD (Child exited) @ 0 (0) ---
rt_sigreturn(0x11)                      = -1 EINTR (Interrupted system
call)
wait4(-1, [WIFSIGNALED(s) && WTERMSIG(s) == SIGSEGV], 0, NULL) = 11962
write(2, "cupsd: Child exited on signal 11"..., 34cupsd: Child exited
on signal 11!
) = 34
exit_group(11)                          = ?
Comment 1 Tim Waugh 2004-02-20 11:29:57 EST
What version of dbus do you have?
Comment 2 Mark Lane 2004-02-20 11:49:41 EST
I thought I already added a comment but it doesn't seem to be here. 
 
dbus-0.20-2 
 
I also tried to rebuild the cups-1.1.20-4 srpm but nroff hung when 
building the backend.1 man page. So groff seems to have a problem 
too but I haven't really looked at it yet. 
 
groff-1.18.1-30 
Comment 3 Tim Waugh 2004-02-20 12:31:56 EST
First of all you need to match the dbus version to the cups version. 
For cups-1.1.20-4 you need dbus-0.20, for prior versions you need
dbus-0.13. (The dependencies *ought* to sort this out, but since the
dbus soname didn't change they might not.)

Could you try ltrace -f on cupsd, so we can get a better idea of where
the child process is having trouble?  Thanks.
Comment 4 Mark Lane 2004-02-20 14:41:18 EST
Created attachment 97878 [details]
output of strace -f cupsd

Okay I figured this morning that I probably need to back out of dbus-0.20 as
well to go back to 1.1.19.

I ran this with cups-1.1.20-4 and dbus-0.20-2 installed.

It says that it's missing the following socket.

connect(5, {sa_family=AF_UNIX, path="/var/run/dbus/system_bus_socket"}, 110) =
-1 ENOENT (No such file or directory)
Comment 5 Tim Waugh 2004-02-23 10:59:36 EST
The strace output doesn't give much, except that it still looks very
much like a mismatch between D-BUS ABIs.

Any luck rebuilding the cups SRPM yet?  If not could you file a bug
against groff for the command line causing the hang?

We can't really debug the cups/dbus problem any further without being
able to rebuild it. (It rebuilds fine here.)
Comment 6 Mark Lane 2004-02-24 09:27:22 EST
I haven't rebuilt cups yet. I did submit a bug against groff though.

I was however able to recompile dbus and messagebus doesn't load
either and wasn't before the recompile. It was complaining about a
missing config file though /etc/dbus-1/ exists and has two config
files in and a system.d directory.

When I get into work, I will attach a trace from the dbus daemon.
Comment 7 Mark Lane 2004-02-24 12:29:27 EST
Created attachment 98000 [details]
strace -f /usr/bin/dbus-daemon-1 >& dbus.trace
Comment 8 Tim Waugh 2004-02-24 12:32:36 EST
You have to run it with --system.  But anyway I don't think strace is
going to help here.
Comment 9 Mark Lane 2004-02-24 13:15:30 EST
Okay I tried that but it went a little farther and segfaulted. 
Comment 10 Mark Lane 2004-02-25 13:50:26 EST
Okay, groff is fixed and I was able to recompile cups-1.1.20-4 but it
still won't start and gives the same error about the missing dbus socket.
Comment 11 Bill Nottingham 2004-02-25 18:41:45 EST
Fixed in dbus-0.20-4.
Comment 12 Mark Lane 2004-02-26 13:01:21 EST
Yeah, I can build dbus-0.20-4, it hangs. I will open a dbus I guess. 

Note You need to log in before you can comment on or make changes to this bug.