Bug 1163380 - passenger-status broken on sat6 on rhel7 [NEEDINFO]
Summary: passenger-status broken on sat6 on rhel7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Infrastructure
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Dominic Cleal
QA Contact: Tazim Kolhar
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1319677 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-12 15:22 UTC by Alex Krzos
Modified: 2019-12-16 05:32 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-15 18:19:52 UTC
Target Upstream Version:
pwayper: needinfo? (bkearney)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1528013 0 None None None Never
Red Hat Knowledge Base (Solution) 2204671 0 None None None 2019-12-16 05:32:45 UTC
Red Hat Product Errata RHBA-2015:1911 0 normal SHIPPED_LIVE Satellite 6.1.3 bug fix update 2015-10-15 22:19:19 UTC

Description Alex Krzos 2014-11-12 15:22:08 UTC
Description of problem:
passenger-status command does not display expected output on Satellite 6 on RHEL7.  This works on Satellite 6 on RHEL6.


Version-Release number of selected component (if applicable):
Sat6-GA-Post-Release-Compose3
candlepin-0.9.23.1-1.el7.noarch
candlepin-common-1.0.1-1.el7.noarch
candlepin-guice-3.0-2_redhat_1.el7.noarch
candlepin-scl-1-5.el7.noarch
candlepin-scl-quartz-2.1.5-6.el7.noarch
candlepin-scl-rhino-1.7R3-3.el7.noarch
candlepin-scl-runtime-1-5.el7.noarch
candlepin-selinux-0.9.23.1-1.el7.noarch
candlepin-tomcat-0.9.23.1-1.el7.noarch
elasticsearch-0.90.10-6.el7sat.noarch
katello-1.5.0-30.el7sat.noarch
katello-certs-tools-1.5.6-1.el7sat.noarch
katello-default-ca-1.0-1.noarch
katello-installer-0.0.64-1.el7sat.noarch
katello-server-ca-1.0-1.noarch
perfc-380g8-01.perf.lab.eng.rdu.redhat.com-qpid-broker-1.0-1.noarch
perfc-380g8-01.perf.lab.eng.rdu.redhat.com-qpid-client-cert-1.0-1.noarch
pulp-katello-0.3-4.el7sat.noarch
pulp-nodes-common-2.4.3-0.1.beta.el7sat.noarch
pulp-nodes-parent-2.4.3-0.1.beta.el7sat.noarch
pulp-puppet-plugins-2.4.3-1.el7sat.noarch
pulp-puppet-tools-2.4.3-1.el7sat.noarch
pulp-rpm-plugins-2.4.3-1.el7sat.noarch
pulp-selinux-2.4.3-1.el7sat.noarch
pulp-server-2.4.3-1.el7sat.noarch
python-gofer-qpid-1.3.0-1.el7sat.noarch
python-isodate-0.5.0-1.pulp.el7sat.noarch
python-kombu-3.0.15-12.pulp.el7sat.noarch
python-pulp-bindings-2.4.3-1.el7sat.noarch
python-pulp-common-2.4.3-1.el7sat.noarch
python-pulp-puppet-common-2.4.3-1.el7sat.noarch
python-pulp-rpm-common-2.4.3-1.el7sat.noarch
python-qpid-0.22-15.el7.noarch
python-qpid-qmf-0.22-37.el7.x86_64
qpid-cpp-client-0.22-42.el7.x86_64
qpid-cpp-server-0.22-42.el7.x86_64
qpid-cpp-server-linearstore-0.22-42.el7.x86_64
qpid-java-client-0.22-7.el7.noarch
qpid-java-common-0.22-7.el7.noarch
qpid-proton-c-0.7-2.el7.x86_64
qpid-qmf-0.22-37.el7.x86_64
qpid-tools-0.22-13.el7.noarch
ruby193-rubygem-katello-1.5.0-92.el7sat.noarch
rubygem-hammer_cli_katello-0.0.4-14.el7sat.noarch
rubygem-smart_proxy_pulp-1.0.1-1.1.el7sat.noarch

ruby193-rubygem-passenger-4.0.18-19.el7sat.x86_64
rubygem-passenger-native-4.0.18-19.el7sat.x86_64
rubygem-passenger-native-libs-4.0.18-19.el7sat.x86_64
ruby193-rubygem-passenger-native-4.0.18-19.el7sat.x86_64
rubygem-passenger-4.0.18-19.el7sat.x86_64
ruby193-rubygem-passenger-native-libs-4.0.18-19.el7sat.x86_64
mod_passenger-4.0.18-19.el7sat.x86_64

How reproducible:
Always on this machine

Steps to Reproduce:
1. Run passenger-status on a Sat6 machine on RHEL7
2.
3.

Actual results:
# passenger-status
*** Phusion Passenger: no passenger_native_support.so found for the current Ruby interpreter. Compiling one (set PASSENGER_COMPILE_NATIVE_SUPPORT_BINARY=0 to disable)...
# mkdir -p /root/.passenger/native_support/4.0.18/ruby-2.0.0-x86_64-linux
# cd /root/.passenger/native_support/4.0.18/ruby-2.0.0-x86_64-linux
# /usr/bin/ruby '/usr/share/gems/gems/passenger-4.0.18/ruby_extension_source/extconf.rb'
/usr/bin/ruby: No such file or directory -- /usr/share/gems/gems/passenger-4.0.18/ruby_extension_source/extconf.rb (LoadError)
Compilation failed.
-------------------------------
Ruby native_support extension not loaded. Continuing without native_support.
ERROR: Phusion Passenger doesn't seem to be running.

Expected results:
# passenger-status
Version : 4.0.18
Date    : Tue Nov 11 08:43:23 -0500 2014
Instance: 10483
----------- General information -----------
Max pool size : 6
Processes     : 6
Requests in top-level queue : 0

----------- Application groups -----------
/usr/share/foreman#default:
  App root: /usr/share/foreman
  Requests in queue: 26
  * PID: 49317   Sessions: 1       Processed: 71987   Uptime: 3h 0m 3s
    CPU: 71%     Memory  : 259M    Last used: 0s ago
  * PID: 48350   Sessions: 1       Processed: 47138   Uptime: 1h 49m 51s
    CPU: 77%     Memory  : 263M    Last used: 0s ago
  * PID: 26517   Sessions: 1       Processed: 18807   Uptime: 39m 15s
    CPU: 88%     Memory  : 115M    Last used: 0s ago
  * PID: 26544   Sessions: 1       Processed: 18673   Uptime: 39m 14s
    CPU: 88%     Memory  : 114M    Last used: 0s ago
  * PID: 26563   Sessions: 1       Processed: 18822   Uptime: 39m 14s
    CPU: 88%     Memory  : 110M    Last used: 0s ago

/etc/puppet/rack#default:
  App root: /etc/puppet/rack
  Requests in queue: 0
  * PID: 15785   Sessions: 0       Processed: 535     Uptime: 53h 23m 14s
    CPU: 0%      Memory  : 84M     Last used: 23m 10s

Additional info:
This command allows you to view the status of the processes and queue within passenger.

Comment 1 RHEL Program Management 2014-11-12 15:26:47 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Alex Krzos 2014-11-12 17:01:56 UTC
The same error exists on capsules as well.

Comment 4 Dominic Cleal 2014-11-13 12:34:16 UTC
Library loading error fixed in 4.0.18-9.6 upstream, however functionality is still broken due to use of PrivateTmp in the httpd unit file, preventing communication between Passenger and external processes.

Comment 5 Dominic Cleal 2014-11-13 12:35:04 UTC
Created redmine issue http://projects.theforeman.org/issues/8392 from this bug

Comment 6 Bryan Kearney 2015-03-19 14:04:31 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/8392 has been closed
-------------
Dominic Cleal
Library loading error fixed in 4.0.18-9.6 (https://github.com/theforeman/foreman-packaging/commit/84a741b819fb1dbce115413f4430698324a468d8), however functionality is still broken due to use of PrivateTmp in the httpd unit file, preventing communication between Passenger and external processes.

I'm thinking I might patch Passenger to set the temp directory to /run, so its sockets are accessible, and then set the buffer directory back to /tmp as it's actually used for large files.

https://www.phusionpassenger.com/documentation/Users%20guide%20Apache.html#PassengerTempDir

The Fedora rawhide packages have the same issue, so will submit a patch there first.
-------------
Dominic Cleal
https://github.com/theforeman/foreman-packaging/compare/theforeman:rpm/develop...domcleal:rpm/develop-8392-passenger-tmpdir uses a patch that the RHSCL Passenger maintainer developed.  Currently got a FTBFS in our Koji instance with EL7 as our EPEL7 mirror's out of date (tag's using epel7-beta), so resolving that first.
-------------
Dominic Cleal
https://github.com/theforeman/foreman-packaging/commit/a66b367702e9d0ee2b8e90dec8a8269153c4829d

Comment 8 Paul Wayper 2015-09-15 03:06:30 UTC
Hi there,

We have a case that is affected by this bug.  I'm not clear what the situation is with systems affected by this bug - does it mean that they are completely incapacitated?  Are they able to continue working but just without "native support" (e.g. just slower)?  Or is it a case of following some installation procedure to get the relevant /usr/share/gems/gems/passenger-4.0.18/ruby_extension_source/extconf.rb file (or fixing the RUBYLIB path to include it) that would allow Passenger to work?

Thanks in advance,

Paul

Comment 11 Tazim Kolhar 2015-10-05 13:19:20 UTC
VERIFIED:

# rpm -qa | grep foreman
ruby193-rubygem-foreman_hooks-0.3.7-2.el7sat.noarch
rubygem-hammer_cli_foreman-0.1.4.14-1.el7sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.13-1.el7sat.noarch
foreman-vmware-1.7.2.40-1.el7sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.7-1.el7sat.noarch
foreman-debug-1.7.2.40-1.el7sat.noarch
foreman-proxy-1.7.2.6-1.el7sat.noarch
foreman-1.7.2.40-1.el7sat.noarch
foreman-gce-1.7.2.40-1.el7sat.noarch
ruby193-rubygem-foreman-redhat_access-0.2.3-1.el7sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el7sat.noarch
hp-xw6600-02.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
hp-xw6600-02.rhts.eng.bos.redhat.com-foreman-proxy-1.0-2.noarch
foreman-compute-1.7.2.40-1.el7sat.noarch
ruby193-rubygem-foreman_docker-1.2.0.22-1.el7sat.noarch
ruby193-rubygem-foreman-tasks-0.6.15.7-1.el7sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.5-1.el7sat.noarch
foreman-libvirt-1.7.2.40-1.el7sat.noarch
foreman-postgresql-1.7.2.40-1.el7sat.noarch
hp-xw6600-02.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-ovirt-1.7.2.40-1.el7sat.noarch
foreman-selinux-1.7.2.13-1.el7sat.noarch
ruby193-rubygem-foreman_discovery-2.0.0.19-1.el7sat.noarch
rubygem-hammer_cli_foreman_docker-0.0.3.9-1.el7sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el7sat.noarch


# passenger-status
Version : 4.0.18
Date    : 2015-10-05 09:14:49 -0400
Instance: 7086
----------- General information -----------
Max pool size : 6
Processes     : 2
Requests in top-level queue : 0

----------- Application groups -----------
/usr/share/foreman#default:
  App root: /usr/share/foreman
  Requests in queue: 0
  * PID: 7044    Sessions: 0       Processed: 0       Uptime: 8m 0s
    CPU: 0%      Memory  : 244M    Last used: 8m 0s ago

/etc/puppet/rack#default:
  App root: /etc/puppet/rack
  Requests in queue: 0
  * PID: 8723    Sessions: 0       Processed: 102     Uptime: 9h 43m 24s
    CPU: 0%      Memory  : 47M     Last used: 13m 19s

Comment 13 errata-xmlrpc 2015-10-15 18:19:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1911

Comment 14 Alessandro Silva 2015-12-04 12:20:49 UTC
Even after the application of errata the error persists:

[root@npaa2235 DOC]# passenger-status
*** Phusion Passenger: no passenger_native_support.so found for the current Ruby interpreter. Compiling one (set PASSENGER_COMPILE_NATIVE_SUPPORT_BINARY=0 to disable)...
# mkdir -p /root/.passenger/native_support/4.0.18/ruby-2.0.0-x86_64-linux
# cd /root/.passenger/native_support/4.0.18/ruby-2.0.0-x86_64-linux
# /usr/bin/ruby '/usr/share/gems/gems/passenger-4.0.18/ruby_extension_source/extconf.rb'
/usr/bin/ruby: No such file or directory -- /usr/share/gems/gems/passenger-4.0.18/ruby_extension_source/extconf.rb (LoadError)
Compilation failed.
-------------------------------
Ruby native_support extension not loaded. Continuing without native_support.
Version : 4.0.18
Date    : 2015-12-03 16:08:59 -0200
Instance: 1156
----------- General information -----------
Max pool size : 24
Processes     : 2
Requests in top-level queue : 0

----------- Application groups -----------
/usr/share/foreman#default:
  App root: /usr/share/foreman
  Requests in queue: 0
  * PID: 14518   Sessions: 0       Processed: 187     Uptime: 23h 28m 25s
    CPU: 0%      Memory  : 260M    Last used: 29m 32s

/etc/puppet/rack#default:
  App root: /etc/puppet/rack
  Requests in queue: 0
  * PID: 6020    Sessions: 0       Processed: 235     Uptime: 23h 29m 34s
    CPU: 0%      Memory  : 43M     Last used: 29m

Comment 15 Ivan Necas 2016-04-26 14:18:50 UTC
*** Bug 1319677 has been marked as a duplicate of this bug. ***

Comment 16 dnguyen 2016-08-31 08:24:49 UTC
[root@satrhs-prd-01 ~]# passenger-status
*** Phusion Passenger: no passenger_native_support.so found for the current Ruby interpreter. Compiling one (set PASSENGER_COMPILE_NATIVE_SUPPORT_BINARY=0 to disable)...
# mkdir -p /root/.passenger/native_support/4.0.18/ruby-2.0.0-x86_64-linux
# cd /root/.passenger/native_support/4.0.18/ruby-2.0.0-x86_64-linux
# /usr/bin/ruby '/usr/share/gems/gems/passenger-4.0.18/ruby_extension_source/extconf.rb'
/usr/bin/ruby: No such file or directory -- /usr/share/gems/gems/passenger-4.0.18/ruby_extension_source/extconf.rb (LoadError)
Compilation failed.
-------------------------------
Ruby native_support extension not loaded. Continuing without native_support.
Version : 4.0.18
Date    : 2016-08-31 10:21:52 +0200
Instance: 15847
----------- General information -----------
Max pool size : 24
Processes     : 24
Requests in top-level queue : 0

----------- Application groups -----------
/usr/share/foreman#default:
  App root: /usr/share/foreman
  Requests in queue: 16
  * PID: 17007   Sessions: 1       Processed: 2087    Uptime: 15m 30s
    CPU: 79%     Memory  : 152M    Last used: 1s ago

/etc/puppet/rack#default:
  App root: /etc/puppet/rack
  Requests in queue: 0
  * PID: 16158   Sessions: 1       Processed: 77      Uptime: 17m 49s
    CPU: 1%      Memory  : 38M     Last used: 12s ago
  * PID: 16165   Sessions: 1       Processed: 99      Uptime: 17m 49s
    CPU: 1%      Memory  : 38M     Last used: 2s ago
  * PID: 16173   Sessions: 1       Processed: 83      Uptime: 17m 49s
    CPU: 1%      Memory  : 38M     Last used: 6s ago
  * PID: 16180   Sessions: 0       Processed: 70      Uptime: 17m 49s
    CPU: 1%      Memory  : 38M     Last used: 22s ago
  * PID: 16187   Sessions: 1       Processed: 74      Uptime: 17m 49s
    CPU: 1%      Memory  : 38M     Last used: 1s ago
  * PID: 16196   Sessions: 1       Processed: 81      Uptime: 17m 49s
    CPU: 1%      Memory  : 38M     Last used: 6s ago
  * PID: 16206   Sessions: 1       Processed: 74      Uptime: 17m 49s
    CPU: 1%      Memory  : 38M     Last used: 2s ago
  * PID: 16216   Sessions: 0       Processed: 81      Uptime: 17m 49s
    CPU: 1%      Memory  : 38M     Last used: 17s ago
  * PID: 16226   Sessions: 0       Processed: 80      Uptime: 17m 49s
    CPU: 1%      Memory  : 38M     Last used: 18s ago
  * PID: 16266   Sessions: 1       Processed: 76      Uptime: 17m 48s
    CPU: 1%      Memory  : 38M     Last used: 6s ago
  * PID: 16290   Sessions: 1       Processed: 75      Uptime: 17m 46s
    CPU: 1%      Memory  : 38M     Last used: 3s ago
  * PID: 16302   Sessions: 0       Processed: 81      Uptime: 17m 44s
    CPU: 1%      Memory  : 38M     Last used: 8s ago
  * PID: 16316   Sessions: 1       Processed: 83      Uptime: 17m 43s
    CPU: 1%      Memory  : 38M     Last used: 1s ago
  * PID: 16330   Sessions: 1       Processed: 71      Uptime: 17m 42s
    CPU: 1%      Memory  : 38M     Last used: 3s ago
  * PID: 16353   Sessions: 1       Processed: 78      Uptime: 17m 41s
    CPU: 1%      Memory  : 38M     Last used: 12s ago
  * PID: 16388   Sessions: 0       Processed: 76      Uptime: 17m 39s
    CPU: 1%      Memory  : 38M     Last used: 14s ago
  * PID: 16400   Sessions: 1       Processed: 84      Uptime: 17m 39s
    CPU: 1%      Memory  : 38M     Last used: 10s ago
  * PID: 16417   Sessions: 0       Processed: 69      Uptime: 17m 37s
    CPU: 1%      Memory  : 38M     Last used: 8s ago
  * PID: 16429   Sessions: 1       Processed: 77      Uptime: 17m 37s
    CPU: 1%      Memory  : 38M     Last used: 11s ago
  * PID: 16481   Sessions: 1       Processed: 75      Uptime: 17m 19s
    CPU: 1%      Memory  : 38M     Last used: 13s ago
  * PID: 16499   Sessions: 0       Processed: 83      Uptime: 17m 17s
    CPU: 1%      Memory  : 39M     Last used: 7s ago
  * PID: 16523   Sessions: 1       Processed: 69      Uptime: 17m 13s
    CPU: 1%      Memory  : 38M     Last used: 13s ago
  * PID: 16545   Sessions: 0       Processed: 72      Uptime: 17m 12s
    CPU: 1%      Memory  : 38M     Last used: 24s ago

Satellite 6.1.9 with errata but same issue with Redhat 7.2


Note You need to log in before you can comment on or make changes to this bug.