Bug 1163382 - UI: Missing route error for forest_delete action in Configuration/Configure/Settings/Authentication
Summary: UI: Missing route error for forest_delete action in Configuration/Configure/S...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.4.0
Assignee: Harpreet Kataria
QA Contact: Nandini Chandra
URL:
Whiteboard:
Depends On:
Blocks: 1163384
TreeView+ depends on / blocked
 
Reported: 2014-11-12 15:27 UTC by Harpreet Kataria
Modified: 2015-06-16 12:44 UTC (History)
2 users (show)

Fixed In Version: 5.4.0.0.11
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1163384 (view as bug list)
Environment:
Last Closed: 2015-06-16 12:44:16 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1100 normal SHIPPED_LIVE CFME 5.4.0 bug fixes, and enhancement update 2015-06-16 16:28:42 UTC

Description Harpreet Kataria 2014-11-12 15:27:34 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Go to Configuration/Configure
2. Select Current server in Settings Accordion
3. Go to Authentication tab
4. change mode to LDAP
5. Check the checkbox for "Get User Groups from LDAP"
6. In "Trusted Forest Settings" box, click on + sign to Add a new forest

Error text:
 not implemented [ops/forest_accept] 
error in log:
[----] F, [2014-11-12T15:19:41.682659 #3360:f01ff4] FATAL -- : Error caught: [ActionController::RoutingError] No route matches {:action=>"forest_delete", :ldaphost_id=>"aaa", :controller=>"ops"}
/home/hkataria/.rvm/gems/ruby-1.9.3-p547/bundler/gems/rails-0cfea19a4279/actionpack/lib/action_dispatch/routing/route_set.rb:540:in `raise_routing_error'

Actual results: getting error


Expected results: should let user add a new forest entry


Additional info:

Comment 1 Harpreet Kataria 2014-11-12 17:09:04 UTC
Steps to Reproduce:
1. Go to Configuration/Configure
2. Select Current server in Settings Accordion
3. Go to Authentication tab
4. change mode to LDAP
5. Check the checkbox for "Get User Groups from LDAP"
6. In "Trusted Forest Settings" box, click on + sign to Add a new forest
7. Enter new Forest details and then press "Add this entry" button.

Comment 2 CFME Bot 2014-11-12 18:55:55 UTC
New commit detected on cfme/master:
https://github.com/ManageIQ/manageiq/commit/e227655ba071d86c8a74ca487c3c16b50c4aa50b

commit e227655ba071d86c8a74ca487c3c16b50c4aa50b
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Wed Nov 12 10:57:59 2014 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Wed Nov 12 10:57:59 2014 -0500

    Added missing 'forest_delete' route
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1163382
    https://bugzilla.redhat.com/show_bug.cgi?id=1163384

 vmdb/config/routes.rb                 | 1 +
 vmdb/spec/routing/ops_routing_spec.rb | 1 +
 2 files changed, 2 insertions(+)

Comment 3 CFME Bot 2014-11-12 18:56:14 UTC
New commit detected on manageiq/master:
https://github.com/ManageIQ/manageiq/commit/e227655ba071d86c8a74ca487c3c16b50c4aa50b

commit e227655ba071d86c8a74ca487c3c16b50c4aa50b
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Wed Nov 12 10:57:59 2014 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Wed Nov 12 10:57:59 2014 -0500

    Added missing 'forest_delete' route
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1163382
    https://bugzilla.redhat.com/show_bug.cgi?id=1163384

 vmdb/config/routes.rb                 | 1 +
 vmdb/spec/routing/ops_routing_spec.rb | 1 +
 2 files changed, 2 insertions(+)

Comment 4 CFME Bot 2014-11-12 19:00:46 UTC
New commit detected on cfme/5.3.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=3c009381c6634221fc607939e0accd38e67321f5

commit 3c009381c6634221fc607939e0accd38e67321f5
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Wed Nov 12 10:57:59 2014 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Wed Nov 12 13:59:35 2014 -0500

    Added missing 'forest_delete' route
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1163382
    https://bugzilla.redhat.com/show_bug.cgi?id=1163384
    (cherry picked from commit e227655)

 vmdb/config/routes.rb                 | 1 +
 vmdb/spec/routing/ops_routing_spec.rb | 1 +
 2 files changed, 2 insertions(+)

Comment 5 Nandini Chandra 2015-03-05 01:18:42 UTC
Verified in master.20150225184803_595ec9e

Comment 7 Shveta 2015-03-13 18:28:29 UTC
Fixed . Verified in 5.4.0.0.11.20150309201930_8b6a235

Comment 9 errata-xmlrpc 2015-06-16 12:44:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1100.html


Note You need to log in before you can comment on or make changes to this bug.