This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 116340 - vmlinux missing in kernel
vmlinux missing in kernel
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-20 03:48 EST by Behdad Esfahbod
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-20 03:50:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Behdad Esfahbod 2004-02-20 03:48:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040115 Epiphany/1.0.7

Description of problem:
From the discussion on another bug I remember that vmlinux is removed
to kernel-debuginfo package.  But there are projects that use vmlinux
to build modules.  Such a project is madwifi
(http://sf.net/projects/madwifi).

Assuming there are projects that need vmlinux to build, and the fact
that kernel-debuginfo is HUGE (300+MB), there's a problem to solve here. 

An stripped vmlinux is 3MB, and the zipped version is of course below
2MB...

Version-Release number of selected component (if applicable):
2.6.2-1.87

How reproducible:
Always

Steps to Reproduce:
1. cd /lib/modules/`uname -r`/
2. ls vmlinux
3.
    

Actual Results:  ls: vmlinux: No such file or directory


Expected Results:  vmlinux


Additional info:
Comment 1 Arjan van de Ven 2004-02-20 03:50:01 EST
we are not going to ship a multi megabyte file just because some
external module has a broken makefile :)
Comment 2 Behdad Esfahbod 2004-02-20 03:56:15 EST
Duh, fast man!
Thanks, that was what I really didn't know.  So you are saying
external modules should not technically need vmlinux to build.  I
would go investigate it in module itself.

Note You need to log in before you can comment on or make changes to this bug.