Bug 11635 - problem with dependency handling during install
Summary: problem with dependency handling during install
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-24 15:45 UTC by Matthew Miller
Modified: 2007-04-18 16:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-12 18:38:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Miller 2000-05-24 15:45:53 UTC
Discovered this while taking the rhce exam, actually.

I did a custom install, and used Select Individual Packages. I removed most
of the sgml stuff, but apparently missed some. The unresolved deps window
came up, saying that something or other depended on jade. I didn't want to
spend more time on it, so I just let it install what it wanted to satisfy
the dependencies.

This didn't work, however. It installed jade, but not sgml-common upon
which jade depends (in fact, it's a prereq). So, the jade package failed to
install properly.

My guess is that the check-deps code is forgetting to go the extra step of
checking dependency information for the packages it suggests.

I haven't looked at the code though. (I'm not yet proficient in Python.) It
might be relevant to note that this was using the text-based interface.

Comment 1 Brock Organ 2000-06-12 18:17:04 UTC
hmmm ... I tried a base install (no package groups selected) and added jade
individually...when prompted for the dependencies screen (ie jade depends on
sgml-common), I chose "Install to satisfy dependencies" ... upon reboot both
jade and sgml-common were installed ...

please let me know the exact package selection you tried that made this fail,
and we'll try to reproduce it and reopen the issue ... thanks for your report!

Comment 2 Matthew Miller 2000-06-12 18:38:00 UTC
Since I was under pressure at the time, I don't have an exact record of what was
installed.  I know that the sgml stuff was chosen by whatever components I
picked -- I removed things from the list rather than adding. I'm not sure that
should make a difference, though. I'll see if I can cause it to happen again,
and I'll reopen this if I can.


Note You need to log in before you can comment on or make changes to this bug.