Bug 116350 - named: named.dyndomain.org.jnl: create: permission denied
named: named.dyndomain.org.jnl: create: permission denied
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: bind (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-20 09:06 EST by Uwe Beck
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-20 14:55:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Uwe Beck 2004-02-20 09:06:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.4) Gecko/20030922

Description of problem:
I configure in named.conf for one zone the dynamic update.

zone "dyndomain.org" IN {
        type master;
        file "named.dyndomain.org";
        // allow-update { 172.16.39.18;172.16.39.206; };
        allow-update { key adsl01.dyndomain.org.; };
};

Now nsupdate send first time a request for update this zone.
This does not work.

cat /var/log/messages
Feb 19 17:07:08 gw-vpn named[15570]: client 172.16.39.18#32784:
updating zone 'named.dyndomain.org/IN': adding an RR
Feb 19 17:07:08 gw-vpn named[15570]: journal file
named.dyndomain.org.jnl does not exist, creating it
Feb 19 17:07:08 gw-vpn named[15570]: named.dyndomain.org.jnl: create:
permission denied

ls -ld /var/named
drwxr-x--- 2 root  named  4096 19. Feb 21:45 /var/named

With this permissions named can not create the *.jnl and can not input
the new records in the zone file, if named will starts new.

Fix for this problem:

chown named /var/named

Now it works correct.

cat /var/log/messages
Feb 19 21:30:34 gw-vpn named[16754]: client 172.16.39.18#32803:
updating zone 'dyndomain.org/IN': adding an RR


Version-Release number of selected component (if applicable):
bind-9.2.2-21

How reproducible:
Always

Steps to Reproduce:
1.configure a zone with allow-update { ...; };
2.send a request for dynamic update to this named
3.
    

Actual Results:  dynymic DNS does not work without correct the
permissions of /var/named

Expected Results:  dynamic DNS should work after install the
bind-9.2.2-x rpm

Additional info:
Comment 1 Daniel Walsh 2004-02-20 09:20:13 EST
You need to put any dynamic data in a subdirectory owned by named. 
Named does not have the right to write to the top level directory.

Dan
Comment 2 Uwe Beck 2004-02-20 09:47:51 EST
I put the dynamic data in a subdirectory owned by named now.
It works correct.
Sorry that I does not remember that. This is not a bug.
Thanks.

Uwe

Note You need to log in before you can comment on or make changes to this bug.