Bug 1163569 - quota xattrs are exposed in lookup and getxattr
Summary: quota xattrs are exposed in lookup and getxattr
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On: 1161106
Blocks: 1162230
TreeView+ depends on / blocked
 
Reported: 2014-11-13 03:21 UTC by Pranith Kumar K
Modified: 2016-02-04 15:08 UTC (History)
1 user (show)

Fixed In Version: glusterfs-v3.6.2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1161106
Environment:
Last Closed: 2016-02-04 15:08:20 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2014-11-13 03:21:13 UTC
+++ This bug was initially created as a clone of Bug #1161106 +++

Description of problem:
quota lookup can return keys apart from quota-limit and quota-size xattrs. getxattr is returning pgfid xattrs. This leads to afr triggering spurious self-heals.

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2014-11-06 06:52:37 EST ---

REVIEW: http://review.gluster.org/9061 (features/marker: Filter internal xattrs in lookup) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Anand Avati on 2014-11-08 03:39:28 EST ---

REVIEW: http://review.gluster.org/9061 (features/marker: Filter internal xattrs in lookup) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Anand Avati on 2014-11-08 03:39:31 EST ---

REVIEW: http://review.gluster.org/9077 (cluster/afr: Ignore quota size key in healing) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Anand Avati on 2014-11-08 20:26:42 EST ---

REVIEW: http://review.gluster.org/9061 (features/marker: Filter internal xattrs in lookup) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Anand Avati on 2014-11-10 00:11:04 EST ---

REVIEW: http://review.gluster.org/9061 (features/marker: Filter internal xattrs in lookup) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Anand Avati on 2014-11-10 02:33:14 EST ---

REVIEW: http://review.gluster.org/9061 (features/marker: Filter internal xattrs in lookup) posted (#5) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Anand Avati on 2014-11-10 10:11:50 EST ---

REVIEW: http://review.gluster.org/9061 (features/marker: Filter internal xattrs in lookup) posted (#6) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Anand Avati on 2014-11-11 06:33:55 EST ---

COMMIT: http://review.gluster.org/9061 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit ffa4263c2f8fcb95ed5553a5a114bc26a920ad27
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Thu Nov 6 10:37:06 2014 +0530

    features/marker: Filter internal xattrs in lookup
    
    Afr should ignore quota-size-key as part of self-heal
    but should heal quota-limit key.
    
    Change-Id: Ic0b06bd20a563a00d6bfdc2dc5a76c661e533ecb
    BUG: 1161106
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/9061
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 1 Anand Avati 2014-11-13 03:24:11 UTC
REVIEW: http://review.gluster.org/9110 (features/marker: Filter internal xattrs in lookup) posted (#1) for review on release-3.6 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Anand Avati 2014-11-17 07:35:29 UTC
COMMIT: http://review.gluster.org/9110 committed in release-3.6 by Vijay Bellur (vbellur@redhat.com) 
------
commit 4bc694954190ce62953e1dfd470f621e85138ccc
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Thu Nov 6 10:37:06 2014 +0530

    features/marker: Filter internal xattrs in lookup
    
            Backport of http://review.gluster.org/9061
    
    Afr should ignore quota-size-key as part of self-heal
    but should heal quota-limit key.
    
    BUG: 1163569
    Change-Id: I93d203002eac4fe20b70730c27c852d783c16d7f
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/9110
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 3 Kaushal 2016-02-04 15:08:20 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v3.6.2, please open a new bug report.

glusterfs-v3.6.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2015/01/glusterfs-3-6-2-ga-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.