Bug 116357 - Network install impossible; forcedeth.ko driver fails to be loaded.
Network install impossible; forcedeth.ko driver fails to be loaded.
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
Reported: 2004-02-20 10:12 EST by Stephen Tweedie
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-03-18 11:06:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
lspci -v; lspci -n (4.81 KB, text/plain)
2004-03-05 06:48 EST, Stephen Tweedie
no flags Details

  None (edit)
Description Stephen Tweedie 2004-02-20 10:12:02 EST
Description of problem:

Using either FC2test1 isos or current rawhide boot.iso, network
install on an X86_64 box with nForce3 networking fails.  Both x86 and
x86_64 boot media fail in the same manner.

During stage 1, I select NFS install.  I'm asked for the network
address, set it for DHCP, and go --- but the screen just cycles back
to the same screen.  

On alt-F3 I see:

* need to set up networking
* going to pick interface
* going to do getNetConfig
* waiting for link...
* 0 seconds
* pump failed: IOCSIFADDR: No such device

and on alt-F4 there is zero activity at all.  jgarzik writes:

sct: it unconditionally printk's "forcedeth.c: Reverse Engineers
nForce ethernet driver, version %s"

so we'd expect to see some kernel output if anaconda even tried to
load the driver.

The forcedeth.ko module is present on the initrd.

Under FC1, I get told "unable to find driver for your network card",
but FC2 does not give that error --- it apparently thinks it has a
driver, it just fails to try to load it.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot.
2. Select NFS install.
3. Ask for DHCP.
Actual results:
No progress past this screen.

Expected results:
Some networking, please!

Additional info:

If I ask for manual network config instead, we progress to the next
screen (setting hostname), but networking is still not set up, no
kernel networking messages appear, alt-f3 shows "no route to host",
and the gethostname fails silently after a timeout.
Comment 1 Stephen Tweedie 2004-02-20 10:13:50 EST
Bill spake:

<notting> sct: the forcedeth change for anaconda (so it knows about
the module) wasn't built until yesterday. rawhide wasn't built today

So I'll try with the next rawhide tree and see if that helps.  Putting
into NEEDINFO for now.

Still, even if anaconda doesn't know about the driver, it should tell
the user that --- FC1 does so correctly, rather than failing silently
to load the driver.
Comment 2 Jeremy Katz 2004-02-22 22:21:45 EST
Right, the module wasn't added until the other day.  As far as
pretending to continue, this is because kudzu is now telling me there
are network devices even when modules haven't loaded, etc  (I haven't
changed the loader code at all)
Comment 3 Bill Nottingham 2004-02-23 00:05:10 EST
Hm, got an example machine to test on?
Comment 4 Stephen Tweedie 2004-02-24 05:47:55 EST
rawhide-20040223 still fails in exactly the same way as before.  Is
anaconda-9.91-0.20040219213330 the latest version?
Comment 5 Jeremy Katz 2004-02-24 23:05:03 EST
There's newer now :)
Comment 6 Stephen Tweedie 2004-02-25 10:52:45 EST
rawhide-20040225 fails in a different way.  Now, choosing "NFS image"
as the install type doesn't work at all: alt-f3 shows 

* need to set up networking
* going to pick interface
* no network devices in choose network device!

alt-f4 shows nothing, and the installer just cycles right back to the
installation method screen without any error diagnostics appearing at all.

There is still no sign of any attempt to load the actual module.
Comment 7 Stephen Tweedie 2004-03-04 09:41:14 EST
rawhide-20040304 tested, same problem.
Comment 8 Jeremy Katz 2004-03-04 12:06:07 EST
Does forcedketh support the ethtool get driver info ioctl?  If not, I
bet that's the problem (since kudzu then doesn't tell anaconda what
device it actually is)
Comment 9 Bill Nottingham 2004-03-04 12:22:52 EST
It *appears* to from looking at the code.
Comment 10 Stephen Tweedie 2004-03-04 16:01:56 EST
But there's no sign that we're ever bothering to load the driver in
the first place.  The module init for forcedeth starts

static int __init init_nic(void)
	printk(KERN_INFO "forcedeth.c: Reverse Engineered nForce ethernet
driver. Version %s.\n", FORCEDETH_VERSION);
	return pci_module_init(&driver);

so we should see an unconditional printk on load, but there's no sign
of that appearing on alt-f4.  After the loader's ohci and iso9660
module messages, there's absolutely nothing appearing when I try to
select the NFS install method.
Comment 11 Bill Nottingham 2004-03-04 16:47:00 EST
Hm. It *does* export PCI entries, so that's not the issue.

Can you attach the output of lspci?
Comment 12 Stephen Tweedie 2004-03-05 06:47:24 EST
The important line for ID purposes is:

00:05.0 Class 0200: 10de:00d6 (rev a5)

Full lspci -n and -v to be attached.
Comment 13 Stephen Tweedie 2004-03-05 06:48:19 EST
Created attachment 98312 [details]
lspci -v; lspci -n
Comment 14 Bill Nottingham 2004-03-05 10:54:23 EST
The modules.pcimap on boot.iso is blank for some reason. Hm.
Comment 15 Jeremy Katz 2004-03-05 12:05:56 EST
Oops, fixed modules.pcimap.  So now seeing if tomorrow's rawhide is
better might actually be useful.
Comment 16 Stephen Tweedie 2004-03-08 10:13:50 EST
Well, it definitely changed the behaviour --- now when I select NFS
install, it tells me I have no supported hardware and drops me into
the driver-disk/select-driver screen.  I can then select forcedeth.ko
manually, and it seems to load just fine according to the alt-f4
messages (I get the same module load diagnostics there as I do from a
normal load of the module.)

But after loading the module, anaconda just takes me back to the
driver-disk/select-driver screen, this time without the option of the
forcedeth driver.
Comment 17 Stephen Tweedie 2004-03-18 11:06:51 EST
Currently works in rawhide.  Thanks!
Comment 18 Jay Hilliard 2005-05-09 16:21:07 EDT
What turned out to be the problem?  And how can I fix this in FC3?

Note You need to log in before you can comment on or make changes to this bug.