Bug 1163660 - Unable to create OpenSSH Key with seahorse
Summary: Unable to create OpenSSH Key with seahorse
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: seahorse
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F21FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2014-11-13 09:04 UTC by Joachim Backes
Modified: 2014-11-22 00:45 UTC (History)
9 users (show)

Fixed In Version: seahorse-3.14.0-3.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-22 00:45:50 UTC
Type: Bug


Attachments (Terms of Use)

Description Joachim Backes 2014-11-13 09:04:27 UTC
Description of problem:
I'm running a fully updated F21.

If I try to add an OpnSSH key with seahorse (Click on OpenSSH keys on the left panel, then click on the + sign at the top of the right panel, select the "Secure Shell item" in the appearing popup, then only seeing a message like 

(seahorse:32544): seahorse-CRITICAL **: seahorse_ssh_generate_show: assertion 'widget != NULL' failed

in the gnome-terminal where I started seahorse.

Clicking again on the + sign, a box appears with 3 buttons "Just create Key", "Cancel" and "Create and Setup" .  But nothing happens if clicking on one of these three buttons.


"Version-Release number of selected component (if applicable):"

seahorse-3.14.0-2.fc21.x86_64


How reproducible:
always

Steps to Reproduce:
1.See description
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Fedora Blocker Bugs Application 2014-11-13 15:32:42 UTC
Proposed as a Blocker for 21-final by Fedora user catanzaro using the blocker tracking app because:

 I can confirm that creating an SSH key with seahorse is broken.  Proposing as a F21 final blocker:

"All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test."

"Basic functionality means that the app must at least be broadly capable of its most basic expected operations"

Seahorse is a tool for creating and managing stored passwords, X.509 certificates, OpenSSH keys, and GnuPG keys. Creating an OpenSSH key is basic functionality.

Comment 2 Michael Catanzaro 2014-11-14 00:53:38 UTC
Seahorse 3.10 is broken with GTK+ 3.14, and Seahorse 3.14 works fine with GTK+ 3.10. I think there was a GTK+ behavior change related to GtkBuilder:

(seahorse:17147): seahorse-WARNING **: could not find widget algorithm-choice for seahorse-ssh-generate.xml

(seahorse:17147): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(seahorse:17147): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(seahorse:17147): seahorse-WARNING **: could not find widget algorithm-choice for seahorse-ssh-generate.xml

(seahorse:17147): seahorse-CRITICAL **: seahorse_ssh_generate_show: assertion 'widget != NULL' failed

The algorithm-choice widget really is in the UI file, though it's used before it's defined....

Comment 3 Michael Catanzaro 2014-11-14 02:52:31 UTC
This bug was first [introduced in, uncovered by] GTK+ 3.13.2. It might be related to [1]

[1] https://git.gnome.org/browse/gtk+/commit/?id=49fa04212b644f19ce576a8011e3f4fcda6a0806

Comment 4 Matthias Clasen 2014-11-14 19:41:11 UTC
Fixes are here:

https://bugzilla.gnome.org/show_bug.cgi?id=740138

Comment 5 Mike Ruckman 2014-11-19 17:27:48 UTC
Discussed in 2014-11-14 blocker review meeting. Ability to create OpenSSH Key is considered as basic functionality of seahorse. So this violates the final criterion: "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test. *Basic functionality means that the app must at least be broadly capable of its most basic expected operations"

Comment 6 Matthias Clasen 2014-11-20 02:07:04 UTC
I don't think POST as a state has any relevance outside RHEL kernel workflows.

Comment 7 Kalev Lember 2014-11-20 11:15:50 UTC
I've backported the fixes to seahorse-3.14.0-3.fc21.

Comment 8 Joachim Backes 2014-11-20 12:32:35 UTC
(In reply to Kalev Lember from comment #7)
> I've backported the fixes to seahorse-3.14.0-3.fc21.

Solves my issue (now I can create OpenSSH keys)

Comment 9 Fedora Update System 2014-11-20 12:40:26 UTC
seahorse-3.14.0-3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/seahorse-3.14.0-3.fc21

Comment 10 Kamil Páral 2014-11-20 13:37:02 UTC
(In reply to Fedora Update System from comment #9)
> seahorse-3.14.0-3.fc21 has been submitted as an update for Fedora 21.
> https://admin.fedoraproject.org/updates/seahorse-3.14.0-3.fc21

This fixes the issue. I can now create a new SSH key without problems.

Comment 11 Fedora Update System 2014-11-22 00:45:50 UTC
seahorse-3.14.0-3.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.