Bug 1163743 - gvfsd-metadata causes high cpu and disk usage
Summary: gvfsd-metadata causes high cpu and disk usage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gvfs
Version: 7.2
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Ondrej Holy
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1210203
TreeView+ depends on / blocked
 
Reported: 2014-11-13 11:48 UTC by Ondrej Holy
Modified: 2019-07-11 08:21 UTC (History)
7 users (show)

Fixed In Version: gvfs-1.16.4-8.el7
Doc Type: Bug Fix
Doc Text:
Cause: When an application tries to save a larger metadata than the size of a journal (e.g. when Firefox saves data URI of downloaded file), it triggers the journal to be flushed to make space for the entry and the operation is then retried, but it never fits, and the loop continues forever. Consequence: It causes constant cpu and disk usage, because gvfsd-metadata deamon creates and deletes new journal files all the time. This could damage the disk. Fix: The operation is retried only once after the flush of journal. Result: The metadata entry isn't saved if it is too large. The deamon prints warning consequently.
Clone Of:
: 1210203 (view as bug list)
Environment:
Last Closed: 2015-03-05 13:34:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0604 0 normal SHIPPED_LIVE gvfs bug fix update 2015-03-05 17:19:46 UTC

Description Ondrej Holy 2014-11-13 11:48:03 UTC
Description of problem:

When an application tries to save a larger key-value pair than the size of the journal (32kb), it triggers the journal to be flushed to make space for the entry and the operation is then retried, but it never fits, and the loop continues forever.

It causes constant cpu and disk usage, because gvfs-metadata creates and deletes files in ~/.local/share/gvfs-metadata/ all the time. This could damage the disk.


How reproducible:

It can be reproduced everytime by saving larger key-value pair than the size of journal (32kb). This bug could be triggered e.g. by Firefox (following steps are copied from upstream bugzilla).


Steps to Reproduce:

1. browse to http://rossl.org/junk/meta.html in Firefox
2. right-click and save the image
3. this should trigger gvfsd-metadata bug, because firefox saves the download URI in metadata::download-uri


Additional info:

The bug was successfully fixed upstream: 
https://bugzilla.gnome.org/show_bug.cgi?id=637095

Provided patch is applicable also for RHEL7 (it is also backported in F19 and F20):
https://bug637095.bugzilla-attachments.gnome.org/attachment.cgi?id=284795

The only way how to stop looping is killing gvfsd-metadata deamon. As a workaround gvfsd-metadata could be disabled (removing its binary /usr/libexec/gvfsd-metadata).

Comment 7 errata-xmlrpc 2015-03-05 13:34:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0604.html


Note You need to log in before you can comment on or make changes to this bug.