Bug 1163771 - Migration via vdsClient not work
Summary: Migration via vdsClient not work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.5.0
Hardware: x86_64
OS: Linux
medium
urgent
Target Milestone: ---
: 3.5.0
Assignee: Francesco Romani
QA Contact: Artyom
URL:
Whiteboard: virt
Depends On:
Blocks: rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-11-13 13:04 UTC by Artyom
Modified: 2015-02-16 13:38 UTC (History)
13 users (show)

Fixed In Version: vt13.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-16 13:38:32 UTC
oVirt Team: ---


Attachments (Terms of Use)
vdsm log from src host (221.06 KB, text/plain)
2014-11-13 13:04 UTC, Artyom
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 35128 master MERGED Change clientIF to get port as string and not as int from config. Never
oVirt gerrit 35230 ovirt-3.5 MERGED virt: migration: simplify the remote port handling Never
oVirt gerrit 35231 ovirt-3.5 MERGED Send to cannonizeHostPort port parameter as string instead of integer. Never

Description Artyom 2014-11-13 13:04:30 UTC
Created attachment 957168 [details]
vdsm log from src host

Description of problem:
Migration between two hosts via vdsClient command not work

Version-Release number of selected component (if applicable):
vdsm-4.16.7.4-1.el6ev.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install ovirt-engine environment with two hosts and one vm, run vm
2. From host where vm run, run vdsClient command:
vdsClient -s 0 migrate vmId=vm_id method=online src=localhost dst=FQDN_of_second host
3.

Actual results:
Thread-167::ERROR::2014-11-13 13:09:49,151::migration::165::vm.Vm::(_recover) vmId=`9f750600-eb90-48df-a19c-1ee564773317`::Failed to destroy remote VM
Traceback (most recent call last):
  File "/usr/share/vdsm/virt/migration.py", line 163, in _recover
    self.destServer.destroy(self._vm.id)
AttributeError: 'SourceThread' object has no attribute 'destServer'
Thread-167::ERROR::2014-11-13 13:09:49,152::migration::259::vm.Vm::(run) vmId=`9f750600-eb90-48df-a19c-1ee564773317`::Failed to migrate
Traceback (most recent call last):
  File "/usr/share/vdsm/virt/migration.py", line 229, in run
    self._setupVdsConnection()
  File "/usr/share/vdsm/virt/migration.py", line 92, in _setupVdsConnection
    self._dst, self._vm.cif.bindings['xmlrpc'].serverPort)
  File "/usr/lib/python2.6/site-packages/vdsm/vdscli.py", line 91, in cannonizeHostPort
    return addr + ':' + port
TypeError: cannot concatenate 'str' and 'int' objects


Expected results:
Migration success

Additional info:
I put this bug under urgent severity, because hosted-engine also use vdsClient command for migration, so it's mean that HA for engine vm not work, because migration not work. Also question why we still for vdsClient use xmlrpc and not jsonrpc, like engine.

Comment 1 Francesco Romani 2014-11-17 14:39:28 UTC
Thanks to Nir Soffer which pointed out that master is not affected due the presence of these patches

3be9ad1f278 virt: migration: simplify the remote port handling
390fa4f757d Send to cannonizeHostPort port parameter as string instead of integer.

I tried the reproduced on master, and I confirm it is indeed not affected.
Verified the issue reproduced on 3.5.
Verified the issue does NOT reproduce if migration is triggered by Engine.
Backported the above two patches on 3.5

The change as per http://gerrit.ovirt.org/35128 needs more work on master, which will be addressed separately.

Comment 2 Michal Skrivanek 2014-11-18 07:43:26 UTC
can you please confirm HE impact. vdsClient was never a supported tool. Also note the xmlrpc question

Comment 3 Jiri Moskovcak 2014-11-18 08:25:07 UTC
(In reply to Michal Skrivanek from comment #2)
> can you please confirm HE impact. vdsClient was never a supported tool. Also
> note the xmlrpc question

Yes, ha-agent uses vdsCli to initiate the migration

Comment 4 Francesco Romani 2014-11-24 08:16:10 UTC
patches backported from master to branch 3.5
http://gerrit.ovirt.org/#/c/35231/
http://gerrit.ovirt.org/#/c/35230/

Comment 5 Artyom 2014-12-14 08:18:06 UTC
Verified on vdsm-4.16.8.1-2.el6ev.x86_64


Note You need to log in before you can comment on or make changes to this bug.